Função SE do Excel Com Exemplos Práticos

Dê um LIKE:+1
Dê um LIKE:+1

A Função SE do Excel pode criar fórmulas preponderantes na condição de cálculos e na construção de recursos lógicos em uma planilha. Confira exemplos práticos da fórmula SE, neste tutorial e aprenda como utilizar em suas planilhas. É possível criar uma condição lógica com esta função aninhada a qualquer outra, por exemplo: procv, soma, média e muitas outras.

Função SE

A fórmula SE retorna um valor, se uma condição for verdadeira e um outro valor, se for falsa. Esta função lógica está entre as mais utilizadas em planilhas para fazer testes lógicos condicionais, quando precisamos alternar entre resultados diferentes.

Com estas você vai aprender criar várias fórmulas construídas com a função SE e saber como usar exemplos aninhados com outras funções de categorias diferentes. Quando acrescentamos fórmulas nas planilhas, elas ficam mais dinâmicas, limpas e com potencial de planilha profissional para impressionar qualquer pessoa que a utilize.

Como Usar a Função SE no Excel?

Existem muitas maneiras de usar fórmulas SE com outras funções de outras categorias, por exemplo: SOMA, PROCV, CONT.SE, E, OU, MÍNIMO e muitas outras. Praticamente qualquer cálculo com fórmulas que você adicionar em sua planilha, poderá criar uma condição com a função SE.

Siga as etapas para criar fórmulas com a condição lógica SE e criar planilhas incríveis que possam ser mais produtivas.

 

Sintaxe da Função SE

SE(Algo for Verdadeiro;mostre resultado X;Caso Contrário;mostre resultado Y)

Isso, diz que você pode definir um valor em uma célula e utilizar os operadores, para calcular o teste lógico. Os operadores para a função SE estão logo abaixo em uma tabela

Argumentos:

  • Teste_lógico - é a condição que será feita através da função, para retornar o valor verdadeiro, ou falso determinado. Este argumento é obrigatório.
  • Valor_se_verdadeiro - é o valor a retornar quando o teste lógico é avaliado como VERDADEIRO, ou seja, se a condição for atendida. Isso também é obrigatório.
  • Valor_se_falso - este argumento representa o valor que será retornando se o resultado do teste for FALSO. Como é uma fórmula de condição lógica, este argumento deve estar presente, embora seja opcional.

Quando você está construindo um teste com a função SE, você pode usar qualquer um dos seguintes operadores lógicos, ou até dois ao mesmo tempo, por exemplo <>, ou >=, ou <= para retornar o valor verdadeiro.

Operadores da sintaxe SE

Símbolo Operador Significado Exemplo
= igual a A1 = D1
> maior que A1> D1
> = maior ou igual a A1> = D1
< menor que A1 < <>
<= menor ou igual a A1 <= D1
<> diferente de A1 <> D1

Exemplo prático da função SE do Excel

A tabela a seguir mostra um exemplo prático e fácil para quem deseja aprender esta função. Então, siga as etapas!

  • Abra o Microsoft Excel.
  • Selecione a tabela a seguir.
  • Copie com o comando Ctrl + C e cole Ctrl + V, na célula A1 de uma nova planilha.
Dicas de Função SE
Saldo de um estoque simbólico
Item Quantidade Estoque Mínimo Relatório
Calculadora 11 7 Estoque OK
Caderno Universitário 15 4 Estoque OK
Caneta Esferográfica 12 5 Estoque OK
Agenda 8 8 Estoque Baixo
Pasta de Arquivos 4 8 Estoque Baixo
Função Usada =SE(B4<=C7;"Estoque Baixo";"Estoque OK")
  • Na célula D4 digite a seguinte função:
=SE(B4>=C4;"Estoque Baixo";"Estoque OK")

Dica: para copiar uma fórmula, para as células seguintes, clique sobre a célula, que contem uma fórmula. Em seguida, posicione o mouse no canto inferior direito da célula e quando o cursor transformar num sinal de cruz, clique, segure e arraste para as demais células. Solte no final.

Depois de copiar, confira se a fórmula foi realmente copiada. Outra forma de copiar e colar é usar as teclas Ctrl + C, para copiar e Ctrl + V, para colar.

Copiar uma fórmula no Excel

Copiar fórmula para outras células

Feito isso, os resultados serão exibidos automaticamente em todas as células, conforme a ação.

Neste exemplo, simulamos uma planilha de estoque, que tem uma definição de estoque mínimo. Se o saldo do item for menor, que o estoque mínimo definido, exibe a mensagem: Estoque Baixo.

Outro Exemplo da Fórmula SE

Agora, vamos utilizar a função SE, para determinar o desconto na venda de carros, de acordo com o combustível.

Copie os dados da tabela a seguir e cole na célula A1 de uma nova planilha de Excel. Você deve ajustar as colunas e consertar as ASPAS, para as fórmulas funcionarem.

Planilha de Exemplo com Fórmulas SE
Carro Combustível Preço Desconto
Modelo 1 Etanol  R$             20.000,00 =SE(B3="Etanol";15%;SE(B3="Gasolina";10%;5%))
Modelo 2 Diesel  R$             34.555,00 =SE(B4="Etanol";15%;SE(B4="Gasolina";10%;5%))
Modelo 3 Gasolina  R$             22.000,00 =SE(B5="Etanol";15%;SE(B5="Gasolina";10%;5%))
Modelo 4 Diesel  R$             40.000,00 =SE(B6="Etanol";15%;SE(B6="Gasolina";10%;5%))
Modelo 5 Gasolina  R$             23.000,00 =SE(B7="Etanol";15%;SE(B7="Gasolina";10%;5%))
Modelo 6 Etanol  R$             18.000,00 =SE(B8="Etanol";15%;SE(B8="Gasolina";10%;5%))

A partir de uma planilha como essa, você pode criar várias funções e acrescentar linhas e colunas.

Dicas:

Todas as funções do Excel sempre são iniciadas com o sinal de igual ( = )

Note, que na função SE; dependendo do seu idioma; o ponto e vírgula deve ser inserido para separar os critérios.

Quando o resultado do critério for um texto, coloca-se entre aspas. O mesmo se aplica na condição. Além disso, a quantidade de parênteses deve ser fechada na mesma quantidade que foi aberta.

Você pode fazer o download de outro exemplo de Função SE que é diferente do que foi explicado aqui.

Baixar Exemplo da Função SE

 

Trabalhando com a Fórmula SE  de forma Aninhada

Em casos onde uma simples fórmula tem apenas dois resultados - Verdadeiro ou Falso, as fórmulas aninhadas à função SE podem ter de 3 a 64 resultados.

Você pode inserir vários critérios em uma função SE. Copie a fórmula a seguir e cole na célula B2 de sua planilha.

=SE(A2="Moto";"Gasolina";SE(A2="Carro";"Etanol";SE(A2="Trator";"Diesel";SE(A2="Barco";"Gás";""))))

Na célula A2, digite Moto e depois vá alterando, conforme os outros critérios da fórmula, para ver a mudança automática, dos resultados verdadeiros da função.

Exemplo da Função SE

Você também pode usar:

=se(A2>=B2;procv(C1;C2:E20;2;falso);0)

Na lógica, estou dizendo que eu quero o resultado na minha células, se a célula A2 for maior ou igual a B2. Além disso se esta condição for verdadeira, deve procurar o valor entre o intervalo C2 a E20, na segunda coluna ( D ). E a referência para achar o resultado está na célula C1.

A imagem a seguir mostra o resultado deste exemplo.

Funções aninhadas

Outras Funções Dentro da lógica SE

A função SE, também pode trabalhar em conjunto com outras funções. Veja a seguir um exemplo.

Copie a fórmula a seguir e cole na célula C2 de sua planilha. Depois digite na célula B2, qualquer valor, ou qualquer texto. Neste caso C2 vai mostrar se B2 está vazia, ou não.

=SE(ÉCÉL.VAZIA(B2);"Em Branco";"Tem Uma Função Nela")

Como já foi dito, outras funções também podem ser usadas, para retornar os resultados de testes verdadeiros, ou falsos. Por exemplo: SOMA, PROCV, OU, E, PROCH, MÉDIA, MÍNIMO e muito mais.

Se você deseja estabelecer o valor mínimo de uma determinada coluna e destacá-la, com a função SE é possível. Basta criar o argumento sobre a função MÍNIMO e determinar a condição.

Copie a fórmula a seguir e cole na célula A9 de sua planilha e digite valores de A2 até A8.

=SE(MÍNIMO($A$2:$A$8)<=2;MÍNIMO($A$2:A8);"Maior 2")

Neste exemplo, se o valor for menor, ou igual a dois, o resultado é verdadeiro.

Problemas Comuns.

Problema O que aconteceu de errado
0 (zero) na célula Não havia um argumento para os argumentos valor_se_verdadeiro valor_se_falso.
Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.
#NOME? na célula Isso geralmente significa que a fórmula está incorreta.

Mais funções Lógicas

Listamos outras funções lógicas, confira!

Espero que você tenha entendido este exemplo e possa criar planilhas complexas e automatizadas. Planilhas eletrônicas devem ser produtivas e a inserção da Função SE, certamente lhe ajudará nesta tarefa.


Edivaldo

Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

114 Comentários
Mostrar Todos Mais Útil Classificação Mais Alta Classificação Mais Baixa Adicionar a sua avaliação
  1. Boa tarde,

    Estou precisando terminar essa formula, tenho que seguir a tabela de IMC, porem somente consegui chegar ate este ponto..
    abaixo segue a tabela, preciso passar a formula a frente para que a mesma chegue ate o fim da tabela, de acrodo com o IMC inserido na planilha.

    =SE(H17<18,5;"MAGREZA";SE(H17<=25;"SAUDAVEL";SE(H1730;"SOBREPESO")))

    IMC Classificação
    < 16 Magreza grave
    16 a < 17 Magreza moderada
    17 a < 18,5 Magreza leve
    18,5 a < 25 Saudável
    25 a < 30 Sobrepeso
    30 a < 35 Obesidade Grau I
    35 a < 40 Obesidade Grau II (severa)
    ≥ 40 Obesidade Grau III (mórbida

    Obrigado.

    • A função estava indo bem até SE(H1730. Esta é a referência, ou seria h17?
      Na última condição, não esqueça de colocar o caso contrário. Lembrando que a função SE faz até 8 condições.

  2. Estou tentando fazer uma a formula se para calcular a porcentagem de comissão sobre valores de faturamento mensal, porém ele calcula certo a primeira condição mas a segunda e terceira esta calculando errado, será que estou fazendo algum calculo errado?

    veja: (VOU SUBSTITUIR AS CELULAS PELO NOME PARA FICAR MAIS CLARO)

    =SE(Faturamento>=50000;Salario+faturamento*tabela de porcentagem); SE(Faturamento>=60000;Salario+faturamento*tabela de porcentagem);SE(Faturamento>=70000;Salario+faturamento*tabela de porcentagem);0)))

    podem me ajudar?

    Grata
    Erika

    • Pelo que eu entendi, as condições de SE, estão pegando a mesma referência.
      =se(a1>=50000;b1*10%;se(a1>=60000;b1*20%;se(a1>=70000;b1*30%;b1)))

      Talvez este exemplo possa te dar uma luz, sobre o que você quer. Sempre crie a condição e uma referência.

  3. Olá Boa Tarde,

    Tenho um caso onde eu preciso utilizar a fórmula =SE para fazer uma multiplicação ou outra mas é com LETRAS.
    Ex. =Se A18 estiver escrito RANDOM então eu multiplico por 1,5 ou se não estiver multiplico por 1.

    Como formulo isso?

    Grato,
    Dener Pereira

    • Excel não calcula texto. Ele pode contar palavras, contar células preenchidas, mas não vai multiplicar um texto, por um valor.
      Talvez você queira definir um valor, para multiplicar, por exemplo:

      a18 está escrito RANDOM e em B18 tem um valor. Dessa forma será possível definir.
      =se(a18="RANDOM";soma(b18*1,5);b18*1)

      talvez sso possa te ajudar, faça este teste.

  4. Olá

    Estou fazendo uma planilha e eu quero que ela copie para outra planilha os dados da linha.
    Digito a turma e o nome do aluno na primeira planilha (plan1), quero que o Excel copie para a segunda planilha de acordo com a turma. Exemplo:

    Digito:

    Maternal Sandro
    1º ano Sofia
    2º Elton
    na primeira

    quero que apareça os nomes dos alunos nos campos referentes a turma (maternal, 1º ou 2º). Como devo fazer.

    Desde já agradeço...

    Sandro Paulino

  5. Srs (a),
    Preciso de ajuda.

    Tenho 3 sequencias numéricas na minha planilha diária, 9, 3 e 7, consigo criar uma formula quer me traga as seguintes informações:

    Ex: =se iniciar com o numero 9, será igual a Matriz
    Ex: =se iniciar com o numero 3, será igual a filial 1
    Ex: =se iniciar com o numero 7, será igual a filial 2

    Ou apenas criando uma macro?

    Obrigado.
    Reinaldo Reis

    • Olá Reinaldo, é apenas para mostrar o texto? Se for use a função SE =se(a1=9;"Matriz";se(a1=3;"Filial 1";se(a1=7;"Filial 2";"";)))
      Agora, se você que iniciar tabelas, que trazem referências da Matriz e das filiais, aí tem que criar as referências também nas tabelas, ou melhor, as funções referentes aos dados de cada tabela. Pode associar a função procv, ou a somase. Já é mais complexo e não da para mostrar aqui, sem ver sua planilha

  6. Olá gente, alguém pode me informar se dá para fazer uma fórmula no excel usando letras? preciso encontrar o valor de X de modo que 200+8.x=300+3.x sei que o resultado é "20" mas preciso fazer no excel.

  7. Boa tarde. Achei muito legal este espaço e adoro trabalhar com o Excel. Tenho a seguinte dúvida: possuo uma planilha que incluem pacientes humanos e veterinários (intervalo de coluna I2:I7259) onde quero contar o número de vezes que uma condição (palavra "medicamento") aparece - então uso a função =CONT.SE($AV$2:$AV$7259;"medicamento"). Entretanto, queria que ele contabilizasse apenas aquelas células que contivesse a condição "humano" no intervalo I2:I7259. Já quebrei bastante a cabeça e não consegui. Você pode me ajudar? Agradeço antecipadamente!

    • Você deve criar uma coluna para humanos, com a função SE e outra para veterinários, também crie a função se.

      na colina para humanos. SE for igual a humanos, preenche o valor 1, caso contrário a célula fica vazia. Depois você usa a função CONT.NUM para contar todas as células que foram preenchidas com 1.

      Repita na coluna para veterinários

    • Olá. tem algumas opções, mas eu vou apresentar uma.

      tente usar a função SE, para humanos e para veterinários, em duas colunas. depois use a função cont.num para obter os resultados da contagem.

      Exemplo: =se(a1=a5;1;"")
      A1 deve ser a referência para humanos. A função deve ser copiada para todas as células da coluna até o final.

      da mesma forma utilize para veterinários.

      Depois escolha dois locais e utilize a função CONT.NUM.

  8. =d6-se(1100-=F4;0;se(1100-<f4) condição não está calculando ? pode me ajudar Muito obrigado

  9. =SE(C41000;30%))

    Quero aumentar o salário de acordo com essas condições mas não aceita! o valor resultante na ficha que tenho é diferente da que obtenho.
    pode dizer o que está errado nessa formula? Obrigada!

    • A fórmula está errada. Tem que ter uma condição, para a fórmula SE. Pelo que eu entendi, a referência é C4 na sua fórmula, então SE C4 = 1000 aumenta 30% caso contrário defina outra condição. C4 pode ser maior, igual, ou menor, que o valor a ser calculado.
      Veja como ficaria: =SE(C4=1000;SOMA(C4*30%)+C4;C4*10%+C4)

      No caso contrario, eu coloquei, que eu aumento seria de 10%.

  10. =SE(H3=MÁXIMO(H$3:$H22);"Melhor vendedor");SE(H3=MÍNIMO(H$3:$H22);"Pior vendedor");SE(H$3<150000;"Fraco";SE(H$3<200000;"Razoável";SE(H$3<250000;"Bom";"Excelente")))))

    o que está de errado nesta fórmula?
    obrigado

    • Está faltando o CASO CONTRÁRIO. só tem a condição SE. Quando termina a condição SE, deve-se adicionar o caso contrário: =SE(A1=B1;"VERDAADEIRO";"FALSO") entendeu?

1 3 4 5 6

Deixe uma Comentário

Tudo Excel
Logo
Shopping cart