Função SE do Excel exemplos práticos

A função SE do Excel retorna um valor, se uma condição for verdadeira e um outro valor, se for falsa. Ela está entre as funções mais utilizadas em planilhas para fazer testes lógicos condicionais. Você vai aprender exemplos a seguir e deixar suas planilhas mais dinâmicas.

Sem dúvidas, ela pode automatizar suas planilhas, com testes lógicos e condições verdadeiras, ou falsas. Por isso a função SE é uma das mais importantes.

Como Usar a Função SE do Excel?

Siga as etapas para criar a função SE. Certamente, Você vai aprender, como trabalhar com recursos básicos e alguns mais avançados.

Sintaxe da Função SE:

SE(Algo for Verdadeiro;mostre resultado X;Caso Contrário;mostre resultado Y)

Isso diz, que você pode definir um valor em uma célula e utilizar os operadores, para calcular o teste lógico.

Argumentos:

  • Teste_lógico - é a condição que será feita através da função, para retornar o valor verdadeiro, ou falso determinado. Este argumento é obrigatório.
  • Valor_se_verdadeiro - é o valor a retornar quando o teste lógico é avaliado como VERDADEIRO, ou seja, se a condição for atendida. Isso também é obrigatório.
  • Valor_se_falso - este argumento representa o valor que será retornando se o resultado do teste for FALSO. Como é uma fórmula de condição lógica, este argumento deve estar presente, embora seja opcional.

Operadores lógicos da função SE

Quando você está construindo um teste com a função SE, você pode usar qualquer um dos seguintes operadores lógicos, ou até dois ao mesmo tempo, por exemplo <>, ou >=, ou <= para retornar o valor verdadeiro.

Símbolo Operador Significado Exemplo
= igual a A1 = D1
> maior que A1> D1
> = maior ou igual a A1> = D1

<

menor que A1<d1< td=""></d1<>

<=

menor ou igual a A1 <= D1

<>

diferente de A1 <> D1

Exemplo prático da função SE do Excel

A tabela a seguir mostra um exemplo prático e fácil para quem deseja aprender esta função. Então, siga as etapas!

  • Abra o Microsoft Excel
  • Selecione a tabela a seguir.
  • Copie com o comando Ctrl + C e cole na célula A1 da planilha.
Dicas de Função SE
Saldo de um estoque simbólico
Item Quantidade Estoque Mínimo Relatório
Calculadora 11 7 estoque OK
Caderno Universitário 15 4 estoque OK
Caneta Esferográfica 12 5 estoque OK
Agenda 8 8 Estoque Baixo
Pasta de Arquivos 4 8 Estoque Baixo
Função Usada =SE(B7>=C7;"Estoque Baixo";"estoque OK")
  • Na célula D4 digite a seguinte função:
=SE(B4>=C4;"Estoque Baixo";"estoque OK")

Dica: para copiar uma fórmula, para as células seguintes, clique sobre a célula, que contem uma fórmula. Em seguida, posicione o mouse no canto inferior direito da célula e quando o cursor transformar num sinal de cruz, clique e arraste para as demais células e solte no final.

Depois confira a fórmula foi realmente copiada. Outra forma de copiar e colar é usar as teclas Ctrl + C, para copiar e Ctrl + V, para colar.

Copiar fórmula para outras células

Feito isso, os resultados serão exibidos automaticamente, conforme a ação.

No exemplo, simulamos uma planilha de estoque, que tem definido o estoque mínimo. Se o saldo do item for menor, que o estoque mínimo definido, exibe a mensagem: Estoque Baixo.

Outro Exemplo de Função SE

Agora, vamos utilizar a função SE, para determinar o desconto na venda de carros, de acordo com o combustível.

Copie os dados da tabela a seguir e cole na célula A1 de uma nova planilha de Excel. Você deve ajustar as colunas e consertar as ASPAS, para as fórmulas funcionarem.

Plnilha de Exemplo da Função SE
Carro Combustível Preço Desconto
Modelo 1 Etanol  R$             20.000,00
=SE(B3="Etanol";15%;SE(B3="Gasolina";10%;5%))
Modelo 2 Diesel  R$             34.555,00
=SE(B4="Etanol";15%;SE(B4="Gasolina";10%;5%))
Modelo 3 Gasolina  R$             22.000,00
=SE(B5="Etanol";15%;SE(B5="Gasolina";10%;5%))
Modelo 4 Diesel  R$             40.000,00
=SE(B6="Etanol";15%;SE(B6="Gasolina";10%;5%))
Modelo 5 Gasolina  R$             23.000,00
=SE(B7="Etanol";15%;SE(B7="Gasolina";10%;5%))
Modelo 6 Etanol  R$             18.000,00
=SE(B8="Etanol";15%;SE(B8="Gasolina";10%;5%))

A partir de uma planilha como essa, você pode criar várias funções e acrescentar linhas e colunas.

Dicas:

Todas as funções do Excel sempre são iniciadas com o sinal de igual ( = )

Note, que na função SE; dependendo do seu idioma; o ponto e vírgula deve ser inserido para separar os critérios.

Quando o valor do critério for texto, coloca-se entre aspas. O mesmo se aplica na condição. Além disso, quantidade de parênteses deve ser fechada na mesma quantidade que foi aberta.

Você pode fazer o download de outro exemplo de Função SE. Mas, este é diferente do que foi explicado aqui.

Trabalhando com Função SE Aninhada

Em casos onde uma simples função SE tem apenas dois resultados - Verdadeiro ou Falso, as funções se aninhadas SE podem ter de 3 a 64 resultados.

Você pode inserir vários critérios em uma função SE. Copie a fórmula a seguir e cole na célula B2 de sua planilha.

=SE(A2="Moto";"Gasolina";SE(A2="Carro";"Etanol";SE(A2="Trator";"Diesel";SE(A2="Barco";"Gás";""))))

Na célula A2, digite Moto e depois vá alterando, conforme os outros critérios da fórmula, para ver a mudança automática, dos resultados verdadeiros da função.

Outras Funções Dentro da Função SE

A função SE, também pode trabalhar em conjunto com outras funções. Veja a seguir um exemplo.

Copie a fórmula a seguir e cole na célula C2 de sua planilha. Depois digite na célula B2, qualquer valor, ou qualquer texto. Neste caso C2 vai mostrar se B2 está vazia, ou não.

=SE(ÉCÉL.VAZIA(B2);"Em Branco";"Tem Uma Função Nela")

Outras funções também podem ser usadas, para retornar os resultados de testes verdadeiros, ou falsos. Por exemplo: SOMA, PROCV, OU, E, PROCH, MÉDIA, MÍNIMO e muito mais.

Se você deseja estabelecer o valor mínimo de uma determinada coluna e destacá-la, com a função SE é possível. Basta criar o argumento sobre a função MÍNIMO e determinar a condição.

Copie a fórmula a seguir e cole na célula A9 de sua planilha e digite valores de A2 até A8.

=SE(MÍNIMO($A$2:$A$8)<=2;MÍNIMO($A$2:A8);"Maior 2")

Neste exemplo, se o valor for menor, ou igual a dois, o resultado é verdadeiro.

Problemas Comuns.

Problema O que aconteceu de errado
0 (zero) na célula Não havia um argumento para os argumentos valor_se_verdadeiro valor_se_falso.
Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.
#NOME? na célula Isso geralmente significa que a fórmula está incorreta.

Espero que você tenha entendido este exemplo e possa criar planilhas complexas e automatizadas.


Edivaldo data: 20/08/2013   ✅ 158449

Envie um Comentário

Você deve estar Logado para postar comentários, ou crie um registro em Tudo Excel.

93 Comentários até agora. Sinta-se livre para se juntar a esta conversa.

  1. CHRYSTIANO SILVA CALADO 23/02/2018 at 11:01 -

    Por favor a formula que estou solicitando ajuda é a seguinte:
    =SE(Z6>15;"NO PRAZO";SE(Z6=8;"ALERTA-1";SE(Z6=4;"ALERTA-2";SE(Z6<=3;"PRORROGAR"))))
    NO PRAZO maior ou = 16
    ALERTA-1 intervalo 15 a 8
    ALERTA-2 intervalo 7 a 4
    PRORROGAR menor ou = 3

    • Edivaldo 23/02/2018 at 16:55 -

      Olá. CHRYSTIANO SILVA CALADO

      Você está esquecendo do caso contrário da função SE. Na fórmula isso é importante, para o caso de adicionar um valor que não esteja dentro dos parâmetros das referências

      =SE(Z6>15;"NO PRAZO";SE(Z6=8;"ALERTA-1";SE(Z6=4;"ALERTA-2";SE(Z6<=3;"PRORROGAR";"Caso contrário fica indefinido")))) No caso contratiro, pode deixar "", ou " " com espaço. A definição é de acordo com a opção do usuário. Copie a fórmula acima, e cole na sua planilha.

  2. CHRYSTIANO SILVA CALADO 23/02/2018 at 10:58 -

    Me desculpem considerar este:
    Por favor estou tentando validar uma situação usando o SE com 4 condições, sendo que a condição "NO PRAZO" está ok, a outra "ALERTA-1" está ok, mas as seguintes "ALERTA-2" e "PRORROGAR" não estão sendo aceitas na formula, gostaria de uma ajuda! Segue a formula:
    =SE(Z6>15;"NO PRAZO";SE(Z6=8;"ALERTA-1";SE(Z6=4;"ALERTA-2";SE(Z6<=3;"PRORROGAR"))))
    Z6 é o resultado da subtração do dia de hoje por um dia programado exemplo hoje 23/02/18, data programada 25/02/18, neste exemplo o resultado seria 3, deveria aparecer no resultado da célula "PRORROGAR", mas não acontece isso! E nem quando também o resultado está entre o intervalo 7 e 4, não aparece na célula "ALERTA-2", por favor me ajuda!

  3. CHRYSTIANO SILVA CALADO 23/02/2018 at 10:53 -

    Por favor estou tentando validar uma situação usando o SE com 3 condições, sendo que a condição "NO PRAZO" está ok, a outra "ALERTA-1" está ok, mas as seguintes "ALERTA-2" e "PRORROGAR" não estão sendo aceitas na formula, gostaria de uma ajuda! Segue a formula:
    =SE(Z6>15;"NO PRAZO";SE(Z6=8;"ALERTA-1";SE(Z6=4;"ALERTA-2";SE(Z6<=3;"PRORROGAR"))))
    Z6 é o resultado da subtração do dia de hoje por um dia programado exemplo hoje 23/02/18, data programada 25/02/18, neste exemplo o resultado seria 3, deveria aparecer no resultado da célula "PRORROGAR", mas não acontece isso! E nem quando também o resultado está entre o intervalo 7 e 4, não aparece na célula "ALERTA-2", por favor me ajuda!

  4. Débora 15/02/2018 at 17:56 -

    Como usar a função SE para retornar um valor de uma coluna ao lado da coluna de referência?
    Exemplo:
    Se o código 123 for igual a célula A4, retornar o valor de B4

    A tabela referência tem uma coluna com o código e outra coluna com o nome do material que estou procurando.
    A planilha da formula, tem apenas o código, e eu gostaria de trazer o nome do produto relativo ao código.

    • Edivaldo 16/02/2018 at 16:52 -

      Olá Débora:
      Basta inserir a fórmula:
      =se(123=a4;b4;"")
      Se o resultado for diferente não retorna nada. Ou pode criar um resultado para diferente. Por exemplo: =se(123=a4;b4;"nenhum resultado")
      Mais informações sobre a função SE neste site.

  5. leandro cardoso 19/01/2018 at 10:26 -

    Como se chega no resultado dessa fórmula =se(A1>A2;C2;B2)

    • Edivaldo 20/01/2018 at 19:41 -

      Oi leandro cardoso, chega-se ao resultado de uma fórmula, inserindo os dados nas referências. Na verdade, eu nunca vi alguém fazer uma fórmula sem saber o resultado.

  6. MARCELO SALLES 10/01/2018 at 19:01 -

    por exemplo: se um número está entre dois valores retorna OK, se não está retorna 0. "N" é maior ou igual a 1 e menor que 2,5, se "N" está contido neste intervalo OK, se não está 0.

  7. Bruno 08/01/2018 at 20:55 -

    Boa noite, tenho uma dúvida quanto a uma função, se é possível ser feita ou não:
    Um valor deve ser multiplicado por 4,09818, se o resultado for:
    1-menor que 5000 não sofre desconto;
    2 – de 5000,01 até 10.000,00 tem um desconto de 8%
    3- de 10.000,01 até 20.000,00 ele sofre desconto de 14%
    4- maior que 20.000,01 sofre um desconto de 19%

    =((j7*4,09818)(SE("5000,01":"10000")-8%)(SE("10000,01":"20000")-14%)(SE>"20000,01";-19%));

    Alguém consegue me ajudar? Desde já agradeço

    • Edivaldo 09/01/2018 at 19:56 -

      Olá Bruno.
      Sua tabela deve ter a fórmula correta da função SE. Você começou a fórmula com o sinal de igual e parêntese, não chama nenhuma função, então não vai funcionar.

      Eu não sei se você quer calcular o desconto sobre o valor de J7, ou o valor multiplicado por 4,09818 e descontar, mas de qualquer forma a fórmula fica mais ou menos assim:

      =SE((J7*4,09818)<5000;J7;SE((J7*4,09818)<10000;SOMA(J7*(1-8%));SE((J7*4,09818)<20000;SOMA(J7*(1-14%));SOMA(J7*(1-19%)))))

      Note que foi usada a fórmula para diminuir porcentagem, se você deseja usar o desconto multiplicando J7*4,09818 basta acrescentar na fórmula.
      Ficou um pouco confuso os detalhe e a fórmula que você mostrou, mas acho que isso já vai te ajudar.