Função SE do Excel Com Exemplos Práticos

A Função SE do Excel pode criar fórmulas preponderantes na condição de cálculos e na construção de recursos lógicos em uma planilha. Confira exemplos práticos da fórmula SE, neste tutorial e aprenda como utilizar em suas planilhas. É possível criar uma condição lógica com esta função aninhada a qualquer outra, por exemplo: procv, soma, média e muitas outras.

Função SE

A fórmula SE retorna um valor, se uma condição for verdadeira e um outro valor, se for falsa. Esta função lógica está entre as mais utilizadas em planilhas para fazer testes lógicos condicionais, quando precisamos alternar entre resultados diferentes.

Com estas você vai aprender criar várias fórmulas construídas com a função SE e saber como usar exemplos aninhados com outras funções de categorias diferentes. Quando acrescentamos fórmulas nas planilhas, elas ficam mais dinâmicas, limpas e com potencial de planilha profissional para impressionar qualquer pessoa que a utilize.

Como Usar a Função SE no Excel?

Existem muitas maneiras de usar fórmulas SE com outras funções de outras categorias, por exemplo: SOMA, PROCV, CONT.SE, E, OU, MÍNIMO e muitas outras. Praticamente qualquer cálculo com fórmulas que você adicionar em sua planilha, poderá criar uma condição com a função SE.

Siga as etapas para criar fórmulas com a condição lógica SE e criar planilhas incríveis que possam ser mais produtivas.

 

Sintaxe da Função SE

SE(Algo for Verdadeiro;mostre resultado X;Caso Contrário;mostre resultado Y)

Isso, diz que você pode definir um valor em uma célula e utilizar os operadores, para calcular o teste lógico. Os operadores para a função SE estão logo abaixo em uma tabela

Argumentos:

  • Teste_lógico - é a condição que será feita através da função, para retornar o valor verdadeiro, ou falso determinado. Este argumento é obrigatório.
  • Valor_se_verdadeiro - é o valor a retornar quando o teste lógico é avaliado como VERDADEIRO, ou seja, se a condição for atendida. Isso também é obrigatório.
  • Valor_se_falso - este argumento representa o valor que será retornando se o resultado do teste for FALSO. Como é uma fórmula de condição lógica, este argumento deve estar presente, embora seja opcional.

Quando você está construindo um teste com a função SE, você pode usar qualquer um dos seguintes operadores lógicos, ou até dois ao mesmo tempo, por exemplo <>, ou >=, ou <= para retornar o valor verdadeiro.

Operadores da sintaxe SE

Símbolo Operador Significado Exemplo
= igual a A1 = D1
> maior que A1> D1
> = maior ou igual a A1> = D1
< menor que A1 < <>
<= menor ou igual a A1 <= D1
<> diferente de A1 <> D1

Exemplo prático da função SE do Excel

A tabela a seguir mostra um exemplo prático e fácil para quem deseja aprender esta função. Então, siga as etapas!

  • Abra o Microsoft Excel.
  • Selecione a tabela a seguir.
  • Copie com o comando Ctrl + C e cole Ctrl + V, na célula A1 de uma nova planilha.
Dicas de Função SE
Saldo de um estoque simbólico
Item Quantidade Estoque Mínimo Relatório
Calculadora 11 7 Estoque OK
Caderno Universitário 15 4 Estoque OK
Caneta Esferográfica 12 5 Estoque OK
Agenda 8 8 Estoque Baixo
Pasta de Arquivos 4 8 Estoque Baixo
Função Usada =SE(B4<=C7;"Estoque Baixo";"Estoque OK")
  • Na célula D4 digite a seguinte função:
=SE(B4>=C4;"Estoque Baixo";"Estoque OK")

Dica: para copiar uma fórmula, para as células seguintes, clique sobre a célula, que contem uma fórmula. Em seguida, posicione o mouse no canto inferior direito da célula e quando o cursor transformar num sinal de cruz, clique, segure e arraste para as demais células. Solte no final.

Depois de copiar, confira se a fórmula foi realmente copiada. Outra forma de copiar e colar é usar as teclas Ctrl + C, para copiar e Ctrl + V, para colar.

Copiar uma fórmula no Excel

Copiar fórmula para outras células

Feito isso, os resultados serão exibidos automaticamente em todas as células, conforme a ação.

Neste exemplo, simulamos uma planilha de estoque, que tem uma definição de estoque mínimo. Se o saldo do item for menor, que o estoque mínimo definido, exibe a mensagem: Estoque Baixo.

Outro Exemplo da Fórmula SE

Agora, vamos utilizar a função SE, para determinar o desconto na venda de carros, de acordo com o combustível.

Copie os dados da tabela a seguir e cole na célula A1 de uma nova planilha de Excel. Você deve ajustar as colunas e consertar as ASPAS, para as fórmulas funcionarem.

Planilha de Exemplo com Fórmulas SE
Carro Combustível Preço Desconto
Modelo 1 Etanol  R$             20.000,00 =SE(B3="Etanol";15%;SE(B3="Gasolina";10%;5%))
Modelo 2 Diesel  R$             34.555,00 =SE(B4="Etanol";15%;SE(B4="Gasolina";10%;5%))
Modelo 3 Gasolina  R$             22.000,00 =SE(B5="Etanol";15%;SE(B5="Gasolina";10%;5%))
Modelo 4 Diesel  R$             40.000,00 =SE(B6="Etanol";15%;SE(B6="Gasolina";10%;5%))
Modelo 5 Gasolina  R$             23.000,00 =SE(B7="Etanol";15%;SE(B7="Gasolina";10%;5%))
Modelo 6 Etanol  R$             18.000,00 =SE(B8="Etanol";15%;SE(B8="Gasolina";10%;5%))

A partir de uma planilha como essa, você pode criar várias funções e acrescentar linhas e colunas.

Dicas:

Todas as funções do Excel sempre são iniciadas com o sinal de igual ( = )

Note, que na função SE; dependendo do seu idioma; o ponto e vírgula deve ser inserido para separar os critérios.

Quando o resultado do critério for um texto, coloca-se entre aspas. O mesmo se aplica na condição. Além disso, a quantidade de parênteses deve ser fechada na mesma quantidade que foi aberta.

Você pode fazer o download de outro exemplo de Função SE que é diferente do que foi explicado aqui.

Baixar Exemplo da Função SE

 

Trabalhando com a Fórmula SE  de forma Aninhada

Em casos onde uma simples fórmula tem apenas dois resultados - Verdadeiro ou Falso, as fórmulas aninhadas à função SE podem ter de 3 a 64 resultados.

Você pode inserir vários critérios em uma função SE. Copie a fórmula a seguir e cole na célula B2 de sua planilha.

=SE(A2="Moto";"Gasolina";SE(A2="Carro";"Etanol";SE(A2="Trator";"Diesel";SE(A2="Barco";"Gás";""))))

Na célula A2, digite Moto e depois vá alterando, conforme os outros critérios da fórmula, para ver a mudança automática, dos resultados verdadeiros da função.

Exemplo da Função SE

Você também pode usar:

=se(A2>=B2;procv(C1;C2:E20;2;falso);0)

Na lógica, estou dizendo que eu quero o resultado na minha células, se a célula A2 for maior ou igual a B2. Além disso se esta condição for verdadeira, deve procurar o valor entre o intervalo C2 a E20, na segunda coluna ( D ). E a referência para achar o resultado está na célula C1.

A imagem a seguir mostra o resultado deste exemplo.

Funções aninhadas

Outras Funções Dentro da lógica SE

A função SE, também pode trabalhar em conjunto com outras funções. Veja a seguir um exemplo.

Copie a fórmula a seguir e cole na célula C2 de sua planilha. Depois digite na célula B2, qualquer valor, ou qualquer texto. Neste caso C2 vai mostrar se B2 está vazia, ou não.

=SE(ÉCÉL.VAZIA(B2);"Em Branco";"Tem Uma Função Nela")

Como já foi dito, outras funções também podem ser usadas, para retornar os resultados de testes verdadeiros, ou falsos. Por exemplo: SOMA, PROCV, OU, E, PROCH, MÉDIA, MÍNIMO e muito mais.

Se você deseja estabelecer o valor mínimo de uma determinada coluna e destacá-la, com a função SE é possível. Basta criar o argumento sobre a função MÍNIMO e determinar a condição.

Copie a fórmula a seguir e cole na célula A9 de sua planilha e digite valores de A2 até A8.

=SE(MÍNIMO($A$2:$A$8)<=2;MÍNIMO($A$2:A8);"Maior 2")

Neste exemplo, se o valor for menor, ou igual a dois, o resultado é verdadeiro.

Problemas Comuns.

Problema O que aconteceu de errado
0 (zero) na célula Não havia um argumento para os argumentos valor_se_verdadeiro valor_se_falso.
Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.
#NOME? na célula Isso geralmente significa que a fórmula está incorreta.

Mais funções Lógicas

Listamos outras funções lógicas, confira!

Espero que você tenha entendido este exemplo e possa criar planilhas complexas e automatizadas. Planilhas eletrônicas devem ser produtivas e a inserção da Função SE, certamente lhe ajudará nesta tarefa.

Confira Estas Planilhas de Excel
Lista de todas as planilhas do site. Confira estas planilhas Premium. Pacote de planilhas de Excel com 17. A melhor opção!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Custo de Obras para construção e reformas de imóveis. Mais vendida! Planilha de Cotação de Preços. Economize dinheiro comprando mais barato!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Orçamento de Obras 2.0. Exatamente o que você precisa para fazer o controle da obra. Planilhas de Controle de Estoque e Vendas. Ótima recomendação para estoques!
Ver Mais Detalhes Ver Mais Detalhes

Edivaldo

Edivaldo

Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

118 Comentários
Mostrar Todos Mais Útil Classificação Mais Alta Classificação Mais Baixa Adicionar a sua avaliação
  1. Olá, Edivaldo!
    Não consigo fazer funcionar estas fórmulas:
    =SE(E(idade>18;altura>=1,80);"Competirá":Nãocompetirá")
    =SE(total de venda>4000;total de venda*3%,0)

    Por favor, me ajude!

    • Olá Nelson Fernando. Nomes devem ficar sempre dentro de aspas. Basta seguir os exemplos desta página com Função SE.

      Por exemplo: =SE(E(idade>18;altura>=1,8);"Competirá";"Não competirá")

      Usamos ponto e vírgula para separar a condição lógica. E este exemplo acima funcionará se renomear as células. Pode adicionar as referências, tipo: A1, B10, etc.

  2. Olá Edivaldo, tudo bem?

    Quero fazer uma fórmula para um intervalo:
    Se a célula for maior que -1 e menor que 1, OK e se for fora desse intervalo, NOK. =SE(A1=-1;"OK";"NOK");NOK);"NOK"). Não consigo fazer dar certo. Obrigada.

    • Olá Priscilla Alvarenga.

      Na sua fórmula tem muitos argumentos: =SE(A1>-1;"OK";se(a1<1;"OK";"NOK")) acho que assim deve funcionar. Por favor testar e me responder.

  3. Olá,
    Quero fazer a seguinte condição: Tenho uma planilha com informações de pedidos que vou lançando o produto que vendi e sua quantidade. Em outra planilha possuo o estoque atual. Quero, que ao lançar o produto específico e por sua quantidade, essa seja automaticamente descontada da planilha, no qual contém o estoque, já atualizando qual o estoque atual após o lançamento daquele item.
    Como posso prosseguir?

  4. Gostaria de receber exercícios sobre Excel médio, por favor. Sou autodidata.

  5. Ola bom dia
    primeiramente obrigado, bem esclarecedor esse post =)
    gostaria de pedir um help. preciso criar uma formula para o controle de estoque
    a planilha funciona assim: tenho a relação de quantidade de itens por produto ex: 5 açúcar, 10 café
    manualmente as pessoas vão la e atualizam automático a quantidade total do estoque, sem gerar informação de quem pegou
    gostaria de criar uma que, você escreve o nome do item ou, que aparecesse na célula aquele botãozinho com os nomes pré definidos
    dos itens, ai do lado a quantidade e a data que foi feito a saída.
    Eu já montei ela e tal, gostaria que me ajudasse em uma formula que calculasse, através do nome do produto e subtraísse da saída o estoque total e atualizasse automaticamente

    deu pra entender?? ahahah desculpa a confusão

  6. Bom dia

    Preciso montar uma formula que me traga uma resposta com base em data

    Se A for maior que 6 meses(Contanto a partir de hoje) "Não", Se for menor "Sim"

    Mas não consigo achar uma forma de fazer funcionar pois a data da Célula A está no formato (dd/mm/aaaa)

  7. E ai Edvaldo, muito bom dia!
    Tudo bem contigo?!?
    Para a 1ª dica "Saldo de um estoque simbólico", estou utilizando a fórmula indicada (=SE(B7>=C7;"Estoque Baixo";"estoque OK")... porém, na linha da "agenda" a quantidade e o estoque são iguais ( 8 e 8), certo?
    No entanto, quanto lanço estes valores na fórmula (=SE(B5>=C5;"Estoque Baixo";"estoque OK"), o resultado que me traz é "estoque OK". Mas deveria ser "Estoque baixo" devido aos sinais ">=".
    Porquê isto está acontecendo?
    Forte abraço e parabéns pelas dicas, conhecimento é a única coisa que ninguém tira de nós...

    Fernando

    • porque, na verdade o "estoque ok" tem que vir primeiro na forma. Porque se a quantidade tem que ser >= o estoque, não faz sentido termos uma série de estoque baixos. Sendo assim a formula fica da seguinte forma: =SE(B2>=C2;"ESTOQUE OK";"ESTOQUE BAIXO").

    • Oi Fernando. Isso acontece mesmo depois que vc adiciona o total de estoque máximo?

  8. =SE(A2="ação";"16 anos";SE(A2="terror";"18 anos";"12 anos"))
    boa tarde qual a formula sobre censura de filmes.
    ação = 16 anos
    terror = 18 anos
    animação = 12 anos
    agradeço desde de já.

    • Oi Antonio Carlos. O Excel não tem fórmulas específicas para censura de filmes, não que eu saiba. Pode ter mas eu ainda não conheço. Porém, podemos criar com a função SE e a sua me parece correta. Eu fiz o teste aqui e é isso ai.

  9. Boa tarde. Me ajuda com uma formula aqui. Tenho uma planilha que mostra quantos meses esta do vencimento. Se tiver 1 mes prox ao venc. Se estiver entre 2 e 6 dentro do prazo de 6 meses e acioma de 7 esta dentro da validade. Como representar na formula >2 e < que 6? Me ajuda nesse quebra cabeça

  10. Boa tarde Edivaldo, porquê que o excel na função se
    Se usar (SE(S63<=6;"[3-6]" se não existir um número menor ou igual a 3, ele assume como falso.

    • Oi Danilo.

      Isso não é uma fórmula de Excel. No meu Excel não funcionou. (SE(S63<=6;"[3-6]". Eu até tentei assim: =(SE(S63<=6;"[3-6]")) mas o resultado foi esse: [3-6]. Porque está entre aspas e significa texto na função SE. Por favor, você pode mandar o que quer fazer?

1 2 3 6

Deixe uma Comentário

Tudo Excel
Logo
Shopping cart