Home Funções Lógicas Função E do Excel determina condição verdadeira

Função E do Excel determina condição verdadeira

A Função E do Excel determina condição verdadeira. Ela pode ser usada e incluída em uma fórmula com a função SE, para determinar o que verdadeira e o caso contrário, determina a condição de FALSO.

212
0

A Função E do Excel determina condição verdadeira. Ela pode ser usada e incluída em uma fórmula com a função SE, para determinar o que verdadeira e o caso contrário, determina a condição de FALSO.

Função E do Excel determina condição verdadeira

A função E retornará VERDADEIRO se todos os seus argumentos forem avaliados como VERDADEIRO e retornará FALSO se um ou mais argumentos forem avaliados como FALSO.

Um uso comum para a função E é expandir a utilidade de outras funções que realizam testes lógicos. Por exemplo, a função SE realiza um teste lógico e, em seguida, retornará um valor se o teste for avaliado como VERDADEIRO. E além disso retornará outro valor se o teste for avaliado como FALSO.

No entanto, usando a função E como argumento teste_lógico da função SE, você pode testar várias condições diferentes em vez de apenas uma.

Sintaxe da função E do Excel

E(lógico1, [lógico2], …)

A sintaxe da função E tem os seguintes argumentos:

Argumento Descrição
Lógico1 Obrigatório. A primeira condição que você deseja testar que pode ser avaliada como VERDADEIRO ou FALSO.
Lógico2; … Opcional. Condições adicionais que você deseja testar que podem ser avaliadas como VERDADEIRO ou FALSO, até um máximo de 255 condições.

Exemplo da função E do Excel

Para ver um exemplo fácil da função E, copie os dados da tabela a seguir e cole-os, na célula A1 de uma nova planilha de Excel. Talvez seja necessário consertar as aspas e excluir os apóstrofos nas fórmulas, para que funcionem.

Exemplo da Função E
Valores
100
200
Resultados Fórmulas Usadas
VERDADEIRO = E (A3> 1; A3 <200)
100 =SE(E(A3<A4;A3<200);A3;”Valor fora do intervalo”)
Valor fora do intervalo =SE(E(A4>1;A4<200);A4;”Valor fora do intervalo”)

Vamos às descrições das fórmulas

Na ordem: primeira, segunda e terceira.
Exibe VERDADEIRO se A3 for maior que 1 e menor que 200. Caso contrário, exibirá FALSO.
Exibe o valor da célula A3 se ele for menor que A4 e menor que 200. Caso contrário, exibirá a mensagem da fórmula.
Exibirá o valor da célula A4 se ele for maior que 1 e menor que 200. Caso contrário, exibirá a mensagem da fórmula.

NOTA: Você pode substituir qualquer mensagem de sua escolha. Você também pode definir valores em uma referência de célula.

Alguns comentários da função E do Excel

Os argumentos devem ser avaliados como valores lógicos, como VERDADEIRO ou FALSO, ou os argumentos devem ser matrizes ou referências que contêm valores lógicos.

Se um argumento de uma matriz ou referência contiver texto ou células vazias, esses valores serão ignorados.

Se o intervalo especificado não contiver valores lógicos, a função E retornará o erro #VALOR!.

Deixe um comentário

avatar
1000
  Subscribe  
Notify of