Função SE do Excel

Por Edivaldo | 20/08/2013 | 152451 leituras

Aprenda a trabalhar com a Função SE do Excel e automatizar suas planilhas, com testes lógicos e condições verdadeiras, ou falsas, essa é talvez a melhor função do programa de planilhas eletrônicas. Ela avalia uma determinada condição e retorna um valor quando você especifica se a condição é VERDADEIRA e outro valor, se a condição for FALSA.

Como Usar a Função SE no Excel?

Nesta postagem nós explicaremos o passo-a-passo da função SE. Você vai aprender, sem dúvidas, como trabalhar com recursos básicos e recursos mais avançados.

Sintaxe da Função SE:

SE(Algo for Verdadeiro;mostre resultado X;Caso Contrário;mostre resultado Y)

Isso diz, que você pode definir um valor em uma célula e utilizar os operadores, para calcular o teste lógico, que você quer aplicar em outra célula.

Argumentos:

  • Teste_lógico – é a condição que será feita através da função, para retornar o valor verdadeiro, ou falso determinado. Este argumento é obrigatório.
  • Valor_se_verdadeiro – e o valor a retornar quando o teste lógico é avaliado como VERDADEIRO, ou seja, se a condição for atendida. Este argumento é obrigatório.
  • Valor_se_falso – este argumento representa o valor que será retornando se o resultado do teste for FALSO. Como é uma fórmula de condição lógica, este argumento deve estar presente, embora seja opcional.

Operadores lógicos

Quando você está construindo um teste com a função SE, você pode usar qualquer um dos seguintes operadores lógicos, ou até dois ao mesmo tempo, por exemplo <>, ou >=, ou <= para retornar o valor verdadeiro.

Símbolo Operador Significado Exemplo
= igual a A1 = D1
> Melhor que A1> D1
> = Maior ou igual a A1> = D1
< menos que A1<d1< td=””></d1<>
<= menos que ou igual a A1 <= D1
<> Não igual a A1 <> D1

Aprendendo na Prática

Agora, que você já sabe a sintaxe e os argumentos da função SE, prepare-se, para aprender na prática. Em um exemplo básico, que fizemos, para você copiar e colar em uma pasta de trabalho do Excel.

  • Abra o Microsoft Excel
  • Copie a tabela a seguir e cole na célula A1 da planilha.
Dicas de Função SE
Saldo de um estoque simbólico
Item Quantidade Estoque Mínimo Relatório
Calculadora 11 7 estoque OK
Caderno Universitário 15 4 estoque OK
Caneta Esferográfica 12 5 estoque OK
Agenda 8 8 Estoque Baixo
Pasta de Arquivos 4 8 Estoque Baixo
Função Usada =SE(B7<=C7;”Estoque Baixo”;”estoque OK”)
  • Na célula D4 digite a seguinte função:
=SE(B4<=C4;"Estoque Baixo";"estoque OK")

Nota: para copiar uma fórmula, para as células seguintes, clique sobre a célula, que já contem uma fórmula, posicione o mouse no canto inferior direito da célula e quando o cursor transformar num sinal de cruz, clique e arraste até a última célula a ser colada a fórmula. Solte-o em seguida. Depois confira as células, para ver se a fórmula foi realmente copiada. Outra forma de copiar e colar é usar as teclas Ctrl + C, para copiar e Ctrl + V, para colar, caso esteja usando um computador com Windows.

resultado – Função SE do Excel

Feito isso, os resultados serão exibidos automaticamente, conforme as mudanças. Em nosso exemplo, simulamos uma planilha de estoque, que tem definido o estoque mínimo. Se o saldo do item for menor, que o estoque mínimo definido, exibe a mensagem: Estoque Baixo. Isso significa, que o item deve ser comprado, para repor o estoque.

Uma função lógica do Excel, que está entre as mais interessantes para o funcionamento de uma planilha é a fórmula SE. Essa função da a condição de se calcular valores, ou adicionar referências em determinadas células da planilha.

Outro Exemplo de Função SE

Neste exemplo vamos ensinar como utilizar a função SE, para impor uma condição de aumento de salário numa tabela simples do Excel.

Dessa vez, não vamos , ter uma planilha, para copiar e colar. Para aprender, você deve criar uma planilha como mostra a figura abaixo. Obedeça a iniciação nas células conforme a imagem, com cabeçalhos na linha 3, começando em B3.

Exemplo da Função SE do Excel

Após o preenchimento das células vamos aplicar a função na coluna F, inicialmente pela célula F4. A fórmula é exatamente igual a que está a mostra na tabela acima.

Primeiro, definimos os critério da seguinte forma:

  1. Se o salário for menor, ou igual a R$ 1000,00 a promoção será de 10%.
  2. Se o salário for menor, ou igual a R$ 1500,00 a promoção será de 8% (isso significa nesse segundo critério, que o salário entre R$ 1000,01 até R$ 1500,00) Note que o primeiro critério já foi definido para o vamor menor, ou igual a mil reais.
  3. O terceiro critério é o caso contrário, ou seja, qualquer valor acima de R$ 1500,00 a promoção será de apenas 6%.

Então a fórmula fica assim:

=SE(E4<=1000;10%;SE(E4<=1500;8%;6%))

Copie a função para as células seguintes, conforme já mostrado acima.

DICAS INTERESSANTES:

Todas as funções do Excel sempre são iniciadas com o sinal de igual ( = )

Note, que na função SE; dependendo do seu idioma; o ponto e vírgula deve ser inserido para separar os critérios, ou seja as partes da fórmula que define cada critério. Isso pode ser aplicado para outras funções.

Quando o valor do critério for texto, coloca-se entre aspas. O mesmo se aplica na condição. Outra dica, quantidade de parênteses a ser fechada é a mesma quantidade de critérios adicionados. Coincide também com a quantidade de parênteses abertos.

Acesse o link para fazer o Download do exemplo de Função SE. Pensou que nós iríamos deixar você sem o exemplo? Só queríamos ver você aprendendo com mais leitura e começando uma planilha do ZERO.

Trabalhando com Função SE Aninhada.

Em casos onde uma simples função SE tem apenas dois resultados – Verdadeiro ou Falso, as funções se aninhadas SE podem ter de 3 a 64 resultados.

Você pode inserir vários critérios em uma função SE. Copie a fórmula a seguir e cole na célula B2 de sua planilha.

=SE(A2="Moto";"Gasolina";SE(A2="Carro";"Etanol";SE(A2="Trator";"Diesel";SE(A2="Barco";"Gás";""))))

Na célula A2, digite Moto e depois vá alterando, conforme os outros critérios da fórmula, para ver a mudança automática, dos resultados verdadeiros da função.

Outras Funções Dentro da Função SE

A função SE, também pode trabalhar em conjunto com outras funções. Veja a seguir um exemplo.

Copie a fórmula a seguir e cole na célula C2 de sua planilha. Depois digite na célula B2, qualquer valor, ou qualquer texto. Neste caso C2 vai mostrar se B2 está vazia, ou não.

=SE(ÉCÉL.VAZIA(B2);"Em Branco";"Tem Uma Função Nela")

Outras funções também cabem dentro da função SE, para retornar os resultados de testes verdadeiros, ou falsos. Por exemplo: SOMA, PROCV, OU, E, PROCH, MÉDIA, MÍNIMO e muito mais.

Se você deseja estabelecer o valor mínimo de uma determinada coluna e destacá-la, com a função SE é possível. Basta criar o argumento sobre a função MÍNIMO e determinar a condição.

Copie a fórmula a seguir e cole na célula A9 de sua planilha e digite valores de A2 até A8.

=SE(MÍNIMO($A$2:$A$8)<=2;MÍNIMO($A$2:A8);"Maior 2")

Neste exemplo, se o valor for menor, ou igual a dois, o resultado é verdadeiro.

Cuidados com a Função SE: dicas do Office.

O Excel permite aninhar até 64 funções SE diferentes, mas não é nada aconselhável fazê-lo. saiba por quê.

  1. Várias instruções SE exigem uma grande quantidade de raciocínio, para serem criadas corretamente e para certificar-se de que sua lógica pode calcular corretamente cada condição, do início ao fim. Se você não aninhar suas instruções SE de forma totalmente precisa, em seguida, uma fórmula poderá funcionar 75% das vezes, mas retornar resultados inesperados 25% das vezes. Infelizmente, são grandes as chances de cair nos 25%.
  2. Várias declarações SE podem se tornar muito difíceis de serem mantidas, especialmente quando você retoma a declaração algum tempo depois e tenta descobrir o que você, ou outra pessoa, estava tentando fazer.
  3. Várias instruções SE exigem vários parênteses de abertura e fechamento (), o que pode ser difícil de gerenciar dependendo da complexidade da sua fórmula.

Problemas Comuns.

Problema O que aconteceu de errado
0 (zero) na célula Não havia um argumento para os argumentos valor_se_verdadeiro valor_se_falso.
Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.
#NOME? na célula Isso geralmente significa que a fórmula está incorreta.

Obrigado por ler esta postagem. Editores de TudoExcel desejam bom aprendizado a você.

Gostaríamos de saber se ficou alguma dúvida sobre: Função SE do Excel. Por favor deixe seu comentário, ou faça sua pergunta.

Você deve estar Logado para postar comentários, ou crie um registro em Tudo Excel.

93 Comentários até agora. Sinta-se livre para se juntar a esta conversa.

  1. CHRYSTIANO SILVA CALADO 23/02/2018 at 11:01 -

    Por favor a formula que estou solicitando ajuda é a seguinte:
    =SE(Z6>15;”NO PRAZO”;SE(Z6=8;”ALERTA-1″;SE(Z6=4;”ALERTA-2″;SE(Z6<=3;"PRORROGAR"))))
    NO PRAZO maior ou = 16
    ALERTA-1 intervalo 15 a 8
    ALERTA-2 intervalo 7 a 4
    PRORROGAR menor ou = 3

    • Edivaldo 23/02/2018 at 16:55 -

      Olá. CHRYSTIANO SILVA CALADO

      Você está esquecendo do caso contrário da função SE. Na fórmula isso é importante, para o caso de adicionar um valor que não esteja dentro dos parâmetros das referências

      =SE(Z6>15;”NO PRAZO”;SE(Z6=8;”ALERTA-1″;SE(Z6=4;”ALERTA-2″;SE(Z6<=3;"PRORROGAR";"Caso contrário fica indefinido")))) No caso contratiro, pode deixar "", ou " " com espaço. A definição é de acordo com a opção do usuário. Copie a fórmula acima, e cole na sua planilha.

  2. CHRYSTIANO SILVA CALADO 23/02/2018 at 10:58 -

    Me desculpem considerar este:
    Por favor estou tentando validar uma situação usando o SE com 4 condições, sendo que a condição “NO PRAZO” está ok, a outra “ALERTA-1” está ok, mas as seguintes “ALERTA-2” e “PRORROGAR” não estão sendo aceitas na formula, gostaria de uma ajuda! Segue a formula:
    =SE(Z6>15;”NO PRAZO”;SE(Z6=8;”ALERTA-1″;SE(Z6=4;”ALERTA-2″;SE(Z6<=3;"PRORROGAR"))))
    Z6 é o resultado da subtração do dia de hoje por um dia programado exemplo hoje 23/02/18, data programada 25/02/18, neste exemplo o resultado seria 3, deveria aparecer no resultado da célula "PRORROGAR", mas não acontece isso! E nem quando também o resultado está entre o intervalo 7 e 4, não aparece na célula "ALERTA-2", por favor me ajuda!

  3. CHRYSTIANO SILVA CALADO 23/02/2018 at 10:53 -

    Por favor estou tentando validar uma situação usando o SE com 3 condições, sendo que a condição “NO PRAZO” está ok, a outra “ALERTA-1” está ok, mas as seguintes “ALERTA-2” e “PRORROGAR” não estão sendo aceitas na formula, gostaria de uma ajuda! Segue a formula:
    =SE(Z6>15;”NO PRAZO”;SE(Z6=8;”ALERTA-1″;SE(Z6=4;”ALERTA-2″;SE(Z6<=3;"PRORROGAR"))))
    Z6 é o resultado da subtração do dia de hoje por um dia programado exemplo hoje 23/02/18, data programada 25/02/18, neste exemplo o resultado seria 3, deveria aparecer no resultado da célula "PRORROGAR", mas não acontece isso! E nem quando também o resultado está entre o intervalo 7 e 4, não aparece na célula "ALERTA-2", por favor me ajuda!

  4. Débora 15/02/2018 at 17:56 -

    Como usar a função SE para retornar um valor de uma coluna ao lado da coluna de referência?
    Exemplo:
    Se o código 123 for igual a célula A4, retornar o valor de B4

    A tabela referência tem uma coluna com o código e outra coluna com o nome do material que estou procurando.
    A planilha da formula, tem apenas o código, e eu gostaria de trazer o nome do produto relativo ao código.

    • Edivaldo 16/02/2018 at 16:52 -

      Olá Débora:
      Basta inserir a fórmula:
      =se(123=a4;b4;””)
      Se o resultado for diferente não retorna nada. Ou pode criar um resultado para diferente. Por exemplo: =se(123=a4;b4;”nenhum resultado”)
      Mais informações sobre a função SE neste site.

  5. leandro cardoso 19/01/2018 at 10:26 -

    Como se chega no resultado dessa fórmula =se(A1>A2;C2;B2)

    • Edivaldo 20/01/2018 at 19:41 -

      Oi leandro cardoso, chega-se ao resultado de uma fórmula, inserindo os dados nas referências. Na verdade, eu nunca vi alguém fazer uma fórmula sem saber o resultado.

  6. MARCELO SALLES 10/01/2018 at 19:01 -

    por exemplo: se um número está entre dois valores retorna OK, se não está retorna 0. “N” é maior ou igual a 1 e menor que 2,5, se “N” está contido neste intervalo OK, se não está 0.

  7. Bruno 08/01/2018 at 20:55 -

    Boa noite, tenho uma dúvida quanto a uma função, se é possível ser feita ou não:
    Um valor deve ser multiplicado por 4,09818, se o resultado for:
    1-menor que 5000 não sofre desconto;
    2 – de 5000,01 até 10.000,00 tem um desconto de 8%
    3- de 10.000,01 até 20.000,00 ele sofre desconto de 14%
    4- maior que 20.000,01 sofre um desconto de 19%

    =((j7*4,09818)(SE(“5000,01″:”10000”)-8%)(SE(“10000,01″:”20000″)-14%)(SE>”20000,01”;-19%));

    Alguém consegue me ajudar? Desde já agradeço

    • Edivaldo 09/01/2018 at 19:56 -

      Olá Bruno.
      Sua tabela deve ter a fórmula correta da função SE. Você começou a fórmula com o sinal de igual e parêntese, não chama nenhuma função, então não vai funcionar.

      Eu não sei se você quer calcular o desconto sobre o valor de J7, ou o valor multiplicado por 4,09818 e descontar, mas de qualquer forma a fórmula fica mais ou menos assim:

      =SE((J7*4,09818)<5000;J7;SE((J7*4,09818)<10000;SOMA(J7*(1-8%));SE((J7*4,09818)<20000;SOMA(J7*(1-14%));SOMA(J7*(1-19%)))))

      Note que foi usada a fórmula para diminuir porcentagem, se você deseja usar o desconto multiplicando J7*4,09818 basta acrescentar na fórmula.
      Ficou um pouco confuso os detalhe e a fórmula que você mostrou, mas acho que isso já vai te ajudar.