Função SE do Excel

Por | | 126314 acessos

A função SE é uma das funções mais procuradas do Microsoft Excel. Para quem trabalha com planilhas e quer automatizá-las, com testes lógicos e condições verdadeiras, ou falsas, esta é talvez a melhor função. Ela avalia uma determinada condição e retorna um valor quando você especifica se a condição é VERDADEIRA e outro valor, se a condição for FALSA.

Como Usar a Função SE no Excel?

Nesta postagem nós explicaremos o passo-a-passo da função SE. Você vai aprender, sem dúvidas, como trabalhar com recursos básicos e recursos mais avançados.

Sintaxe da Função SE:

SE(Algo for Verdadeiro;mostre resultado X;Caso Contrário;mostre resultado Y)

Isso diz, que você pode definir um valor em uma célula e utilizar os operadores, para calcular o teste lógico, que você quer aplicar em outra célula.

Argumentos:

  • Teste_lógico – é a condição que será feita através da função, para retornar o valor verdadeiro, ou falso determinado. Este argumento é obrigatório.
  • Valor_se_verdadeiro – e o valor a retornar quando o teste lógico é avaliado como VERDADEIRO, ou seja, se a condição for atendida. Este argumento é obrigatório.
  • Valor_se_falso – este argumento representa o valor que será retornando se o resultado do teste for FALSO. Como é uma fórmula de condição lógica, este argumento deve estar presente, embora seja opcional.

Operadores lógicos

Quando você está construindo um teste com a função SE, você pode usar qualquer um dos seguintes operadores lógicos, ou até dois ao mesmo tempo, por exemplo <>, ou >=, ou <= para retornar o valor verdadeiro.

Símbolo Operador Significado Exemplo
= igual a A1 = D1
> Melhor que A1> D1
> = Maior ou igual a A1> = D1
< menos que A1<d1< td=””></d1<>
<= menos que ou igual a A1 <= D1
<> Não igual a A1 <> D1

Aprendendo na Prática

Agora, que você já sabe a sintaxe e os argumentos da função SE, prepare-se, para aprender na prática. Em um exemplo básico, que fizemos, para você copiar e colar em uma pasta de trabalho do Excel.

  • Abra o Microsoft Excel
  • Copie a tabela a seguir e cole na célula A1 da planilha.
Dicas de Função SE
Saldo de um estoque simbólico
Item Quantidade Estoque Mínimo Relatório
Calculadora 11 7 estoque OK
Caderno Universitário 15 4 estoque OK
Caneta Esferográfica 12 5 estoque OK
Agenda 8 8 Estoque Baixo
Pasta de Arquivos 4 8 Estoque Baixo
Função Usada =SE(B7<=C7;”Estoque Baixo”;”estoque OK”)
  • Na célula D4 digite a seguinte função:
=SE(B4<=C4;"Estoque Baixo";"estoque OK")
  • Agora copie a função para as células seguintes até D8. Se a fórmula estiver aparecendo na tela, exclua o apóstrofo, antes do sinal de igual.

Nota: para copiar uma fórmula, para as células seguintes, clique sobre a célula, que já contem uma fórmula, posicione o mouse no canto inferior direito da célula e quando o cursor transformar num sinal de cruz, clique e arraste até a última célula a ser colada a fórmula. Solte-o em seguida. Depois confira as células, para ver se a fórmula foi realmente copiada. Outra forma de copiar e colar é usar as teclas Ctrl + C, para copiar e Ctrl + V, para colar, caso esteja usando um computador com Windows.

Feito isso, os resultados serão exibidos automaticamente, conforme as mudanças. Em nosso exemplo, simulamos uma planilha de estoque, que tem definido o estoque mínimo. Se o saldo do item for menor, que o estoque mínimo definido, exibe a mensagem: Estoque Baixo. Isso significa, que o item deve ser comprado, para repor o estoque.

Uma função lógica do Excel, que está entre as mais interessantes para o funcionamento de uma planilha é a fórmula SE. Essa função da a condição de se calcular valores, ou adicionar referências em determinadas células da planilha.

Outro Exemplo de Função SE

Neste exemplo vamos ensinar como utilizar a função SE, para impor uma condição de aumento de salário numa tabela simples do Excel.

Dessa vez, não vamos , ter uma planilha, para copiar e colar. Para aprender, você deve criar uma planilha como mostra a figura abaixo. Obedeça a iniciação nas células conforme a imagem, com cabeçalhos na linha 3, começando em B3.

Após o preenchimento das células vamos aplicar a função na coluna F, inicialmente pela célula F4. A fórmula é exatamente igual a que está a mostra na tabela acima.

Primeiro, definimos os critério da seguinte forma:

  1. Se o salário for menor, ou igual a R$ 1000,00 a promoção será de 10%.
  2. Se o salário for menor, ou igual a R$ 1500,00 a promoção será de 8% (isso significa nesse segundo critério, que o salário entre R$ 1000,01 até R$ 1500,00) Note que o primeiro critério já foi definido para o vamor menor, ou igual a mil reais.
  3. O terceiro critério é o caso contrário, ou seja, qualquer valor acima de R$ 1500,00 a promoção será de apenas 6%.

Então a fórmula fica assim:

=SE(E4<=1000;10%;SE(E4<=1500;8%;6%))

Copie a função para as células seguintes, conforme já mostrado acima.

DICAS INTERESSANTES:

Todas as funções do Excel sempre são iniciadas com o sinal de igual ( = )

Note, que na função SE; dependendo do seu idioma; o ponto e vírgula deve ser inserido para separar os critérios, ou seja as partes da fórmula que define cada critério. Isso pode ser aplicado para outras funções.

Quando o valor do critério for texto, coloca-se entre aspas. O mesmo se aplica na condição. Outra dica, quantidade de parênteses a ser fechada é a mesma quantidade de critérios adicionados. Coincide também com a quantidade de parênteses abertos.

Acesse o link para fazer o Download do exemplo de Função SE. Pensou que nós iríamos deixar você sem o exemplo? Só queríamos ver você aprendendo com mais leitura e começando uma planilha do ZERO.

Trabalhando com Função SE Aninhada.

Em casos onde uma simples função SE tem apenas dois resultados – Verdadeiro ou Falso, as funções se aninhadas SE podem ter de 3 a 64 resultados.

Você pode inserir vários critérios em uma função SE. Copie a fórmula a seguir e cole na célula B2 de sua planilha.

=SE(A2="Moto";"Gasolina";SE(A2="Carro";"Etanol";SE(A2="Trator";"Diesel";SE(A2="Barco";"Gás";""))))

Na célula A2, digite Moto e depois vá alterando, conforme os outros critérios da fórmula, para ver a mudança automática, dos resultados verdadeiros da função.

Outras Funções Dentro da Função SE

A função SE, também pode trabalhar em conjunto com outras funções. Veja a seguir um exemplo.

Copie a fórmula a seguir e cole na célula C2 de sua planilha. Depois digite na célula B2, qualquer valor, ou qualquer texto. Neste caso C2 vai mostrar se B2 está vazia, ou não.

=SE(ÉCÉL.VAZIA(B2);"Em Branco";"Tem Uma Função Nela")

Outras funções também cabem dentro da função SE, para retornar os resultados de testes verdadeiros, ou falsos. Por exemplo: SOMA, PROCV, OU, E, PROCH, MÉDIA, MÍNIMO e muito mais.

Se você deseja estabelecer o valor mínimo de uma determinada coluna e destacá-la, com a função SE é possível. Basta criar o argumento sobre a função MÍNIMO e determinar a condição.

Copie a fórmula a seguir e cole na célula A9 de sua planilha e digite valores de A2 até A8.

=SE(MÍNIMO($A$2:$A$8)<=2;MÍNIMO($A$2:A8);"Maior 2")

Neste exemplo, se o valor for menor, ou igual a dois, o resultado é verdadeiro.

Cuidados com a Função SE: dicas do Office.

O Excel permite aninhar até 64 funções SE diferentes, mas não é nada aconselhável fazê-lo. saiba por quê.

  1. Várias instruções SE exigem uma grande quantidade de raciocínio, para serem criadas corretamente e para certificar-se de que sua lógica pode calcular corretamente cada condição, do início ao fim. Se você não aninhar suas instruções SE de forma totalmente precisa, em seguida, uma fórmula poderá funcionar 75% das vezes, mas retornar resultados inesperados 25% das vezes. Infelizmente, são grandes as chances de cair nos 25%.
  2. Várias declarações SE podem se tornar muito difíceis de serem mantidas, especialmente quando você retoma a declaração algum tempo depois e tenta descobrir o que você, ou outra pessoa, estava tentando fazer.
  3. Várias instruções SE exigem vários parênteses de abertura e fechamento (), o que pode ser difícil de gerenciar dependendo da complexidade da sua fórmula.

Problemas Comuns.

Problema O que aconteceu de errado
0 (zero) na célula Não havia um argumento para os argumentos valor_se_verdadeiro valor_se_falso.
Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.
#NOME? na célula Isso geralmente significa que a fórmula está incorreta.

Obrigado por ler esta postagem. Editores de TudoExcel desejam bom aprendizado a você.

 

 

Gostaríamos de saber se ficou alguma dúvida sobre: Função SE do Excel. Por favor deixe seu comentário, ou faça sua pergunta.

atualizado em:26/09/2017 Excel

 

Envie um comentário, ou faça uma pergunta:
 

Degite o número que corresponde ao resultado *

 

80 Comments até agora. Sinta-se livre para se juntar a esta conversa.

  1. JOSIANE 06/10/2017 at 15:10 - Reply

    Gostaria de ajuda para a questão abaixo, estou preenchendo uma planilha de resultados em %. Se o % lançado for menor que 80%, deve zerar e se for maior de 250% deve ser 250, mas se for qualquer outro numero do intervalo, deve ser o numero digitado, é possível?

    • Tudo Excel 06/10/2017 at 23:23 - Reply

      É só usar as combinações dos critérios da função. Sim é possível

  2. Robson 01/10/2017 at 21:01 - Reply

    Estou tendo dificuldade para calcular o valor de venda de um produto.
    Tenho as seguintes informações na planilha:
    Tenho o valor do custo Unitário de um produto
    Ex. 10,00

    Tenho vários códigos referente a porcentagem que ira calcular o valor do produto
    Exemplo dos códigos
    A2=20%
    A25=25%
    A3=30%

    quando uma célula recebe o código informado para calculo da porcentagem, gostaria que calculasse o valor 10,00 + 20% = 12,00 reais

  3. Érik da Silva Pereira 20/09/2017 at 17:37 - Reply

    Preciso de ajuda para usar a função SE no Excel para data e hora, poderia me ajudar

    Se a data e hora colocada chegar, colocar OK
    Se a data e hora não tiver chegado, colocar Pendente

    • Tudo Excel 21/09/2017 at 21:51 - Reply

      Faça a referência em uma célula de ponha a condição. Nesta mesma página explica como fazer.

  4. Aline 06/09/2017 at 21:00 - Reply

    Estou tentando fazer uma formula que após a PROCV
    o que ficar #N/DISP seja igual BLOQUEADO
    e quando aparacer o
    código do cliente ( V00000 ) seja LIBERADO.
    Já tentei e não consegui pelo
    http://www.tudoexcel.com.br/planilhas/funcao-de-excel-procv-247.html

  5. Maêssa 31/08/2017 at 12:07 - Reply

    Boa tarde!
    Estou tentando fazer uma fórmula para calcular de acordo com o total de vendas do vendedor, a meta que ele conquistou.
    Mais n está dando certo rsrs
    A função que coloco é essa:
    =SE(H11>=B19;”50,00″;SE(H11>=B20;”120,00″;SE(H11>=B21;”200,00″;”ZERO”)))
    Mais o valor das vendas já está na segunda condição, e o Excel só dá o resultado da primeira condição.
    Vcs podem me dizer o que poderia estar acontecendo?
    Coloquei a fórmula dessa maneira tambèm:
    =SE(H11>=B19;D19;SE(H11>=B20;D20;SE(H11>=B21;D21;”ZERO”)))
    Mais o Resultado só aparece o da cédula D19, assim como na fórmula anterior só aparece os “50,00” da primeira condição.

    • Tudo Excel 31/08/2017 at 19:40 - Reply

      Aqui a fórmula funcionou:
      =SE(B19>=H11;”50,00″;SE(B20>=H11;”120,00″;SE(B21>=H11;”200,00″;”ZERO”)))

      tem que alimentar todas as células, para que funcione. Só tem uma coisa, eu não entendi porque essa condição começa em B19 e termina em B21. Mas a fórmula funcionou sim.

  6. helio 15/08/2017 at 16:51 - Reply

    Olá, gostaria de uma fórmula que identificasse de uma coluna o que é celular e o que é fixo, coluna adjacente, com numeros começando com 9 (cel) e outros numeros (fixo). Obrigado

    • Tudo Excel 15/08/2017 at 16:56 - Reply

      Olá… Use a função SE, ou função SES. Procure em Funções e depois clique em Funções Logicas, para achar e ver como usar

  7. Walber Miranda Costa 11/08/2017 at 23:50 - Reply

    Queria fazer uma fórmula com os seguintes dados.
    Digitar o nome de um agente e no campo seguinte ele automaticamente informar a matrícula, por exemplo

    Carlos Eduardo (iria colocar em lista suspensa) 569752 (matrícula automaticamente preenchida)

    Como fazer isso?

  8. ANTONIO 23/07/2017 at 12:38 - Reply

    =SE(MÉDIA(A1:A5)=3;SOMA(B1:B5);10) COMO SE LÊ ESSA FORMULA, E O QUE SIGNIFICA O 10 NO FINAL?

    • Tudo Excel 26/07/2017 at 18:58 - Reply

      Olá. Não sabemos para que esta fórmula foi adicionada, mas ler o seguinte:
      Se a média entre a1 e a5 for igual a três, exibe a soma de b1 até b5, caso contrário exibe 10.

  9. angelica 12/07/2017 at 11:35 - Reply

    bom dia, preciso de formula para:
    ex: o valor cobrado de um frete é 100,00, porem o valor que recebo em cima deste é 25%, ou seja R$25,00. então uso a formula =célula 100,00 x 0,25 para que seja dado o resultado.
    Mais se o valor dos 25% sobre o frete for menor que 15,00 (eu recebo independente se for 1,00 ou 14,99) sempre 15,00, poderia me ajudar, gostaria de colocar em mesma celula estas duas informarcoes. tipo se menor que 15 , que apareça 15 ou o valor acima de 15,00

    muito obrigada.

  10. LUAN NASCIMENTO 10/07/2017 at 12:46 - Reply

    Olá, poderiam me ajudar com essa condição;

    =SE(Q9>100%;”ERRO”;SE(E(Q9=90%));”EXCELENTE”;SE(E(Q970%));”BOM”;SE(E(Q950%));”REGULAR”;SE(E(Q9=100%));

    • Tudo Excel 10/07/2017 at 17:36 - Reply

      Olá. Talvez sua função SE funcione corretamente assim:

      =SE(Q9>100%;”ERRO”;SE(E(Q9=90%);”EXCELENTE”;SE(E(Q9=70%);”BOM”;SE(E(Q9=50%);”REGULAR”;SE(E(Q9=100%);”Faltou essa condição”)))))

      Estava faltando a ultima condição e o fechamento dos parênteses.