Função SE do Excel exemplos práticos

A função SE do Excel retorna um valor, se uma condição for verdadeira e um outro valor, se for falsa. Ela está entre as funções mais utilizadas em planilhas para fazer testes lógicos condicionais. Você vai aprender exemplos a seguir e deixar suas planilhas mais dinâmicas.

Sem dúvidas, ela pode automatizar suas planilhas, com testes lógicos e condições verdadeiras, ou falsas. Por isso a função SE é uma das mais importantes.

Como Usar a Função SE do Excel?

Siga as etapas para criar a função SE. Certamente, Você vai aprender, como trabalhar com recursos básicos e alguns mais avançados.

Sintaxe da Função SE:

SE(Algo for Verdadeiro;mostre resultado X;Caso Contrário;mostre resultado Y)

Isso diz, que você pode definir um valor em uma célula e utilizar os operadores, para calcular o teste lógico.

Argumentos:

  • Teste_lógico - é a condição que será feita através da função, para retornar o valor verdadeiro, ou falso determinado. Este argumento é obrigatório.
  • Valor_se_verdadeiro - é o valor a retornar quando o teste lógico é avaliado como VERDADEIRO, ou seja, se a condição for atendida. Isso também é obrigatório.
  • Valor_se_falso - este argumento representa o valor que será retornando se o resultado do teste for FALSO. Como é uma fórmula de condição lógica, este argumento deve estar presente, embora seja opcional.

Operadores lógicos da função SE

Quando você está construindo um teste com a função SE, você pode usar qualquer um dos seguintes operadores lógicos, ou até dois ao mesmo tempo, por exemplo <>, ou >=, ou <= para retornar o valor verdadeiro.

Símbolo Operador Significado Exemplo
= igual a A1 = D1
> maior que A1> D1
> = maior ou igual a A1> = D1
< menor que A1 < <>
<= menor ou igual a A1 <= D1
<> diferente de A1 <> D1

Exemplo prático da função SE do Excel

A tabela a seguir mostra um exemplo prático e fácil para quem deseja aprender esta função. Então, siga as etapas!

  • Abra o Microsoft Excel
  • Selecione a tabela a seguir.
  • Copie com o comando Ctrl + C e cole na célula A1 da planilha.
Dicas de Função SE
Saldo de um estoque simbólico
Item Quantidade Estoque Mínimo Relatório
Calculadora 11 7 estoque OK
Caderno Universitário 15 4 estoque OK
Caneta Esferográfica 12 5 estoque OK
Agenda 8 8 Estoque Baixo
Pasta de Arquivos 4 8 Estoque Baixo
Função Usada =SE(B7>=C7;"Estoque Baixo";"estoque OK")
  • Na célula D4 digite a seguinte função:
=SE(B4>=C4;"Estoque Baixo";"estoque OK")

Dica: para copiar uma fórmula, para as células seguintes, clique sobre a célula, que contem uma fórmula. Em seguida, posicione o mouse no canto inferior direito da célula e quando o cursor transformar num sinal de cruz, clique e arraste para as demais células e solte no final.

Depois confira a fórmula foi realmente copiada. Outra forma de copiar e colar é usar as teclas Ctrl + C, para copiar e Ctrl + V, para colar.

Copiar fórmula para outras células

Feito isso, os resultados serão exibidos automaticamente, conforme a ação.

No exemplo, simulamos uma planilha de estoque, que tem definido o estoque mínimo. Se o saldo do item for menor, que o estoque mínimo definido, exibe a mensagem: Estoque Baixo.

Outro Exemplo de Função SE

Agora, vamos utilizar a função SE, para determinar o desconto na venda de carros, de acordo com o combustível.

Copie os dados da tabela a seguir e cole na célula A1 de uma nova planilha de Excel. Você deve ajustar as colunas e consertar as ASPAS, para as fórmulas funcionarem.

Plnilha de Exemplo da Função SE
Carro Combustível Preço Desconto
Modelo 1 Etanol  R$             20.000,00 =SE(B3="Etanol";15%;SE(B3="Gasolina";10%;5%))
Modelo 2 Diesel  R$             34.555,00 =SE(B4="Etanol";15%;SE(B4="Gasolina";10%;5%))
Modelo 3 Gasolina  R$             22.000,00 =SE(B5="Etanol";15%;SE(B5="Gasolina";10%;5%))
Modelo 4 Diesel  R$             40.000,00 =SE(B6="Etanol";15%;SE(B6="Gasolina";10%;5%))
Modelo 5 Gasolina  R$             23.000,00 =SE(B7="Etanol";15%;SE(B7="Gasolina";10%;5%))
Modelo 6 Etanol  R$             18.000,00 =SE(B8="Etanol";15%;SE(B8="Gasolina";10%;5%))

A partir de uma planilha como essa, você pode criar várias funções e acrescentar linhas e colunas.

Dicas:

Todas as funções do Excel sempre são iniciadas com o sinal de igual ( = )

Note, que na função SE; dependendo do seu idioma; o ponto e vírgula deve ser inserido para separar os critérios.

Quando o valor do critério for texto, coloca-se entre aspas. O mesmo se aplica na condição. Além disso, quantidade de parênteses deve ser fechada na mesma quantidade que foi aberta.

Você pode fazer o download de outro exemplo de Função SE. Mas, este é diferente do que foi explicado aqui.

Trabalhando com Função SE Aninhada

Em casos onde uma simples função SE tem apenas dois resultados - Verdadeiro ou Falso, as funções se aninhadas SE podem ter de 3 a 64 resultados.

Você pode inserir vários critérios em uma função SE. Copie a fórmula a seguir e cole na célula B2 de sua planilha.

=SE(A2="Moto";"Gasolina";SE(A2="Carro";"Etanol";SE(A2="Trator";"Diesel";SE(A2="Barco";"Gás";""))))

Na célula A2, digite Moto e depois vá alterando, conforme os outros critérios da fórmula, para ver a mudança automática, dos resultados verdadeiros da função.

Outras Funções Dentro da Função SE

A função SE, também pode trabalhar em conjunto com outras funções. Veja a seguir um exemplo.

Copie a fórmula a seguir e cole na célula C2 de sua planilha. Depois digite na célula B2, qualquer valor, ou qualquer texto. Neste caso C2 vai mostrar se B2 está vazia, ou não.

=SE(ÉCÉL.VAZIA(B2);"Em Branco";"Tem Uma Função Nela")

Outras funções também podem ser usadas, para retornar os resultados de testes verdadeiros, ou falsos. Por exemplo: SOMA, PROCV, OU, E, PROCH, MÉDIA, MÍNIMO e muito mais.

Se você deseja estabelecer o valor mínimo de uma determinada coluna e destacá-la, com a função SE é possível. Basta criar o argumento sobre a função MÍNIMO e determinar a condição.

Copie a fórmula a seguir e cole na célula A9 de sua planilha e digite valores de A2 até A8.

=SE(MÍNIMO($A$2:$A$8)<=2;MÍNIMO($A$2:A8);"Maior 2")

Neste exemplo, se o valor for menor, ou igual a dois, o resultado é verdadeiro.

Problemas Comuns.

Problema O que aconteceu de errado
0 (zero) na célula Não havia um argumento para os argumentos valor_se_verdadeiro valor_se_falso.
Para receber o valor correto, adicione um texto de argumento aos dois argumentos, ou adicione VERDADEIRO ou FALSO ao argumento.
#NOME? na célula Isso geralmente significa que a fórmula está incorreta.

Espero que você tenha entendido este exemplo e possa criar planilhas complexas e automatizadas.

As pessoas estão lendo isso também:

Função VERDADEIRO no Excel
Função XOR do Excel Teste Agora

105 Comments

  1. Fernando 14/09/2019
    • Edivaldo 19/09/2019
  2. Antonio Carlos 27/08/2019
    • Edivaldo 27/08/2019
  3. TEOSBOURNE 24/02/2019
    • Edivaldo 28/02/2019

Leave a Reply