Como Usar a Função SOMA no Excel

A função SOMA no Excel, retorna a soma dos valores fornecidos como múltiplos argumentos. SOMA pode lidar com até 255 argumentos individuais, que podem incluir números, referências de células, intervalos, ordens e constantes.

Sintaxe da Função SOMA

SOMA(número1;[número2];...)

Exemplo: =soma(10+15)

Se 10 estiver na célula A1 e 15 estiver na célula A2, podemos usar =soma(A1+A2), =soma(A1:A2), ou ainda =A1+a2

Vamos ao exemplo prático:

Copie a tabela a seguir e cole na célula A1 de uma nova planilha de Excel. Você pode apenas excluir os apóstrofos das fórmulas, para fazê-las funcionar. Selecione as células, que contem as fórmulas, uma de cada vez e veja na barra de fórmulas o apóstrofo antes do sinal de igual.

Função SOMA
10 25 =10+15
15 25 =SOMA(A2+A3)
25 =SOMA(A2:A3)

A tabela acima mostra alguns exemplos básicos de função soma.

Esta é a função mais básica e fácil de usar no Excel, mas pode se tornar complexa, se sua planilha tiver muitas referências e precisar multiplicar, subtrair e, ou dividir, valores com a soma.

Outros exemplos de Fórmulas com a função SOMA.

=soma(10+5)/3

Somamos 10 mais 5, que é igual a 15 e dividimos por 3 para achar o resultado 5.

=SOMA(10*10+20)/2-5

Multiplicamos 10 vezes 10, que é igual a 100, mais 20, que é igual a 120. depois dividimos por 20 e ainda diminuímos por 5. Resultado é igual á 55.

Você pode copiar as fórmulas acima e colar em qualquer parte da planilha de Excel.

O que pode ser incluídos na função SOMA, veja a seguir a tabela de operadores e os exemplos, que podem ser utilizados.

Operador Operação Exemplos
+ Adição =5+5
=A1+B1
=SOMA(A1:A10)+20
=SOMA(A1:A10)+B1
- Subtração =10-9
=A1-B1
=SOMA(A1:A10)-20
=SOMA(A1:A10)-B1
* Multiplicação =2*2
=A1*B1
=SOMA(A1:A10)*2
=SOMA(A1:A10)*B1
=PRODUTO(1;1) – Função PRODUTO
/ Divisão =2/1
=A1/B1
=SOMA(A1:A10)/10
=SOMA(A1:A10)/B1
=QUOCIENTE (1;1) – Função QUOCIENTE
^ Exponenciação =3^3
=A1^B1
=SOMA(A1:A10)^3
=SOMA(A1:A10)^B1
=POTÊNCIA(1;1) – Função POTÊNCIA

Usando o Assistente de Auto Soma

  • A maneira mais fácil de adicionar uma fórmula de SOMA à planilha é usar o Assistente de AutoSoma. Selecione uma célula vazia diretamente acima ou abaixo do intervalo que você deseja somar. Na faixa de opções Página Inicial, localize o grupo Edição e clique no sinal de auto soma.
  • Quando a fórmula aparecer na célula selecionada, selecione o intervalo de células, que será somado.

Práticas recomendadas com SOMA.

Agora nós vamos mostrar algumas práticas recomendadas para trabalhar com a função SOMA. Grande parte delas também pode ser aplicada em conjunto com outras funções.

  • Método =1+2 ou =A+B – embora seja possível inserir =1+2+3 ou =A1+B1+C2 e obter resultados totalmente precisos, esses métodos estão sujeitos a erros por vários motivos:

Erros de digitação - se você tentar inserir vários valores e valores maiores, ou fracionados, pode haver erros de digitação e o resultado será impreciso.

Exemplo: =14598,93+65437,90+78496,23

Verifique sempre se suas entradas estão corretas. É muito mais fácil colocar esses valores em células individuais e usar uma fórmula de SOMA. Além disso, é possível formatar os valores quando eles estão nas células, tornando-os muito mais legíveis.

  • Erros #VALOR! de referência de texto em vez de números

Se você usar uma fórmula como:

=A1+B1+C1 ou =A1+A2+A3. Este é um exemplo de uma construção de fórmula ruim.

Sua fórmula pode ser interrompida se houver valores não numéricos, como textos, nas células referenciadas, que retornarão um erro #VALUE!. A função SOMA ignora valores de texto e fornece somente a soma dos valores numéricos.

Construção de fórmula adequada. Em vez de =A1+B1+C1, a fórmula da célula D1 fórmula é =SOMA(A1:C1)

  • Erro #REF! de exclusão de linhas ou colunas

Erro #REF! causado pela exclusão de uma coluna A fórmula mudou para =A2+#REF!+B2

Se você excluir uma linha ou coluna, a fórmula não será atualizada para excluir a linha excluída e retornará um erro #REF!, em que uma função SOMA será atualizada automaticamente.

A função SOMA se ajusta automaticamente a colunas e linhas inseridas ou excluídas

  • As fórmulas não atualizarão referências ao inserir linhas ou colunas

As fórmulas =A+B+C não serão atualizadas se você adicionar linhas
Se inserir uma linha ou coluna, a fórmula não será atualizada para incluir a linha adicionada, em que uma função soma será atualizada automaticamente (desde que você não esteja fora do intervalo referenciado na fórmula). Isso é especialmente importante se você espera que a fórmula atualize, pois ela não será atualizada e dará resultados incompletos que você poderá não perceber.

O exemplo retrata uma fórmula de SOMA expandindo automaticamente de =SOMA(A2:C2) para =SOMA(A2:D2) quando uma coluna foi inserida

  • SOMA com Referências de célula individuais versus Intervalos.

Usando uma fórmula como:

=SOMA(A1;A2;A3;B1;B2;B3)

Também está bastante sujeito a erros durante a inserção, ou exclusão de linhas dentro do intervalo referenciado pelas mesmas razões. É muito melhor usar intervalos individuais, como:

=SOMA(A1:A3;B1:B3)

Que serão atualizados ao adicionar ou excluir linhas.

Todas as funções do Excel começam com o sinal de igual. depois do nome da função, geralmente vem os parênteses. Você deve fechar sempre o mesmo total de parênteses que foi aberto, para construir a fórmula.


Edivaldo

Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

Teremos o maior prazer em ouvir seus pensamentos

Deixe uma Comentário

Tudo Excel
Logo
Shopping cart