Função PROCV do Excel Como Usar

Por | | 2947 acessos

A Função PROCV é uma ferramenta extremamente útil e aprender usá-la é mais fácil do que você imagina. Use a função PROCV, quando precisar localizar algo em linhas de uma tabela, ou de um intervalo. Por exemplo, para pesquisar o preço de um determinado produto na planilha, pelo código do produto.

Antes de começar, você deve entender o básico das funções. Confira nossa lista de funções do Excel, e aprenda todas de forma muito fácil. O PROCV funciona da mesma forma em todas as versões do Excel, além de também funcionar em outras aplicações de planilhas, como o Google Sheets, Open Office, etc. Veja a tabela a seguir, com os elementos dos argumentos desta função.

Argumentos da Função PROCV

Nome do argumento Descrição
valor_procurado – argumento obrigatório O valor que você deseja procurar deve estar na primeira coluna do intervalo de células especificado na matriz_tabela.
Por exemplo: se a matriz_tabela abrange as células A2:A10, então valor_procurado deverá estar na coluna A. O valor_procurado pode ser um valor, ou uma referência a uma célula.
matriz_tabela – argumento obrigatório É o intervalo de células em que PROCV procurará pelo valor_procurado e pelo valor de retorno.
A primeira coluna no intervalo de células deve conter o valor_procurado. por exemplo, o Sobrenome na imagem abaixo. O intervalo de células também deve incluir o valor de retorno que você deseja localizar. Por exemplo: o Nome na imagem abaixo.
Como fazer planilhas com funções do Excel
núm_índice_coluna – argumento obrigatório O número da coluna (começando em 1 para a coluna mais à esquerda da matriz-tabela) que contém o valor de retorno.
intervalo_pesquisa – argumento opcional Um valor lógico que especifica se você quer que a PROCV localize uma correspondência aproximada ou exata:
VERDADEIRO supõe que a primeira coluna na tabela é classificada em ordem alfabética ou numérica e, em seguida, procura o valor mais próximo. Esse será o método padrão, se você não especificar um.
FALSO procura o valor exato na primeira coluna.

Exemplo Prático da função PROCV

Copie o exemplo a seguir e cole na célula A1 de uma nova planilha de Excel. Depois copie a fórmula da célula B14 e cole na célula C3. Em seguida copie a fórmula da célula B15 e cole na célula D3. Para que as fórmulas mostrem os resultados, exclua o apóstrofo, que eventualmente esteja antes do sinal de igual (‘=).

Função PROCV do Excel
Procura código >> fru003 Goiaba  R$                     8,00
CÓDIGO NOME MEDIDA PREÇO
FRU001 Laranja KG  R$                  12,00
FRU002 Macã KG  R$                  16,00
FRU003 Goiaba KG  R$                     8,00
FRU004 Banana KG  R$                     4,50
FRU005 Graviola KG  R$                     5,00
LEG001 Beterraba KG  R$                     3,60
LEG002 Cenoura KG  R$                     4,00
Fórmulas Usada =PROCV(B3;A5:D12;2;FALSO) produto
=PROCV(B3;A5:D12;4;FALSO) preço

Sua planilha deve ficar com o formato parecido com a imagem já postada acima. As cores são opcionais.

Resolvendo erros #N/D

Quando você inserir uma fórmula, na função PROCV e deixar a célula de referência vazia, pode retornar o erro #N/D. Para evitar isso, adicione a função SE.

Incluindo a Função SE na fórmula

Pegando o exemplo desta postagem, crie a fórmula da seguinte maneira:

=SE(B3="";"";PROCV(B3;A5:D12;2;FALSO))

Adicione também para a outra fórmula. Neste caso, se a célula de referência estiver vazia, as células que contem a fórmula da função PROCV, permanecerão como vazias. Mas se digitar um valor que não existe dentro da coluna, que a fórmula deve buscar o resultado, retornará também um erro #N/D.

 

 

Gostaríamos de saber se ficou alguma dúvida sobre: Função PROCV do Excel Como Usar. Por favor deixe seu comentário, ou faça sua pergunta.

atualizado em:24/09/2017 Excel

 

Envie um comentário, ou faça uma pergunta:
 

Degite o número que corresponde ao resultado *