Função ÍNDICE, confira exemplos no Excel planilhas e VBA

Este Tutorial demonstra como usar a Função ÍNDICE do Excel, que está na categoria Funções de pesquisa e referência, para retornar um valor com base em referências de coluna e linha. Crie tabelas incríveis com uma das funções mais apropriadas para usar.

Exemplo da função Indice

ÍNDICE(matriz; núm_linha; [núm_coluna])

O formulário de matriz da função ÍNDICE tem os seguintes argumentos:

  • matriz Obrigatório. Um intervalo de células ou uma constante de matriz.

  • Se a matriz contiver apenas uma linha ou coluna, o argumento row_num ou column_num correspondente será opcional.
  • Se a matriz tiver mais de uma linha e mais de uma coluna e somente row_num ou column_num for usada, ÍNDICE retornará uma matriz de toda a linha ou coluna na matriz.

  • núm_linha Obrigatório, a menos que column_num esteja presente. Seleciona a linha na matriz a partir da qual um valor deverá ser retornado. Se row_num for omitido, column_num será necessário.
  • column_num Opcional. Seleciona a coluna na matriz a partir da qual um valor deverá ser retornado. Se column_num for omitido, row_num será necessário.

Sintaxe e argumento da função ÍNDICE

=ÍNDICE(matriz;núm_linha;[núm_coluna];[núm_área])

array -Um intervalo de células ou uma constante de array.

  • núm_linha – a posição da linha na referência ou matriz.
  • núm_coluna – [opcional] A posição da coluna na referência ou matriz.
  • area_num – [opcional] O intervalo em referência que deve ser usado.

Exemplo básico da função ÍNDICE

Queremos poder dizer à nossa fórmula para escolher um item específico da lista com base na posição. Vamos supor que queremos o terceiro item da lista. Em D1, colocamos o número 3. Em D2, colocamos a fórmula

=ÍNDICE(A2:A5, D1)

Como B2 é 3, nosso índice retornará a 3ª célula desse intervalo, que é A4. O valor de A4 é "Limão" e assim temos esse resultado.

Copie o exemplo abaixo e cole na célula A1 de uma nova planilha de Excel

dados Índice
Laranja 3
Maçã Limão
Limão fórmula usada
Banana =ÍNDICE(A2:A5; B2)

Exemplo de tabela com a função Índice

Agora vamos construir uma tabela de referência para encontrar o valor da fórmula índice. Você pode copiar esta tabela e colar na célula A1 de uma nova planilha de Excel, para fazer seus próprios testes.

Exemplo da função ÍNDICE
3 1 6 3 4 Referencias( F3, F4) Resultado
1 9 16 23 30 5 44
8 10 17 19 6 4
3 5 14 25 32 (linha 5 e coluna 4) Fórmula Usada na célula G3
4 12 19 44 8 =ÍNDICE(A2:E8;F3;F4)
5 13 12 27 16
6 14 21 28 35

A fórmula encontrou o resultado da linha 5 que cruza com a coluna 4 e o resultado encontrado foi 44.

Função INDEX, confira exemplos no Excel

Embora usar ÍNDICE aqui para encontrar valores numéricos seja um pouco redundante, você também pode usar isso para retornar strings de texto.

Usando com a função CORRESP

A função ÍNDICE é frequentemente usada em conjunto com a função CORRESP, que retorna a posição relativa de um item. Vejamos um exemplo de livro de notas em que nosso professor deseja fornecer uma disciplina e um nome de aluno e encontrar a nota correspondente.

Função ÍNDICE
Grade José Andreia Maria Joaquim
Matemática 7,9 9,9 7,5 9,8 Assunto Ciências
Ciências 8 8,9 9,4 10 Estudante Maria
Português 9,8 8,5 9,1 9 Nota 9,4
Geografia 10 9 10 9
Fórmula usada
=ÍNDICE(B3:E6;CORRESP(G3;A3:A6;0);CORRESP(G4;B2:E2;0))

Na tabela acima queremos saber qual nota a aluna Maria tirou em Ciências. Copie esta tabela e cole na célula A1 de uma nova planilha de Excel, para fazer testes e ver como funciona incrivelmente bem.

Exemplo básico de ÍNDICE em VBA

Você também pode usar a função ÍNDICE no VBA, como neste exemplo bem básico exibido a seguir:

application.worksheetfunction.index(array,row_num,column_num)

Para os argumentos da função (array, etc.), você pode inseri-los diretamente na função ou definir variáveis ​​a serem usadas.

Supondo que temos os seguintes dados em nossa planilha. As referências das células são simbólicas e você pode alterar de acordo como está em sua planilha. Eu não suporte para VBA, mas às vezes adiciono alguns exemplos básico aqui no site.

Podemos usar a função ÍNDICE da seguinte forma

WorksheetFunction.Index(Range("B2:F6");3;3)

Isso retornará 18 (Célula D4), porque é a célula localizada na terceira linha e terceira coluna da célula em nosso intervalo definido B2:F6

WorksheetFunction.Index(Range("Table2");2;4)

Isso retornará 51 (Célula E3), pois é a célula localizada na segunda linha e na quarta coluna da Tabela2

Também podemos definir mais de um intervalo, como segue. Observe que estamos usando mais um parâmetro desta vez (o último "1"), que define o intervalo do qual o valor deve ser retornado

WorksheetFunction.Index(Range("B2:F6,I4:M8");2;5;1)

Isso retornará 36 (Célula F3), porque é a célula localizada na segunda linha e quinta coluna em nosso primeiro intervalo definido, que é a Tabela2

WorksheetFunction.Index(Range("B2:F6;I2:M6");4;3;2)

Isso retornará 115 (Célula K5), porque é a célula localizada na quarta linha e terceira coluna em nosso segundo intervalo definido, que é I2:M6

Espero ter ajudado a entender um pouco da função ÍNDICE para o MS Excel.

Confira Estas Planilhas de Excel
Lista de todas as planilhas do site. Confira estas planilhas Premium. Pacote de planilhas de Excel com 17. A melhor opção!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Custo de Obras para construção e reformas de imóveis. Mais vendida! Planilha de Cotação de Preços. Economize dinheiro comprando mais barato!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Orçamento de Obras 2.0. Exatamente o que você precisa para fazer o controle da obra. Planilhas de Controle de Estoque e Vendas. Ótima recomendação para estoques!
Ver Mais Detalhes Ver Mais Detalhes

Edivaldo

Edivaldo

Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

Teremos o maior prazer em ouvir seus pensamentos

Deixe uma Comentário

Tudo Excel
Logo
Shopping cart