Criando Fórmulas Complexas no Excel

No Excel, voc√™ pode criar f√≥rmulas aninhadas em v√°rias fun√ß√Ķes. √Č necess√°rio compreender v√°rias fun√ß√Ķes como: Logica, Matem√°tica, Procura de refer√™ncia, entre outras, para incorporar uma dentro da outra. Pegamos como base uma planilha de pre√ßos, onde o propriet√°rio dos produtos concede descontos.

Para trabalhar com fórmulas complexas do Excel, é importante criar referências. Se você vai criar uma tabela para promover descontos, por exemplo, você cria em uma célula a opção Desconto, em seguida determina o valor, ou o percentual.

Exemplo: A2 = desconto e em A3 digita o valor. A3 é a referência.

Na tabela a seguir, temos os exemplos de f√≥rmulas complexas. Copie e cole na c√©lula A1 de uma nova planilha e tente reproduzir as f√≥rmulas da √ļltima c√©lula na c√©lulas acima. Os valores v√£o surgindo e quando voc√™ alterar as refer√™ncias os dados mudar√£o automaticamente.

Tabela de preços com desconto Digite apenas nas células pintadas
TAXA MENSAL Data DESCONTO Total  parcelas Prazo medio
2,00% 18-jan-18 20,00% 6 100 dias
APARELHOS NOVOS
No MODELO PREÇO AVISTA ENTRADA FIXA VALOR FINANCIADO  6 VEZES VALOR A PAGAR PREÇO DESCONTO
1 Produto 01          100,00            106,82              17,80          106,82              83,33
2 Produto 02            41,00              43,80                7,30            43,80              34,17
3 Produto 03            54,00  R$  15,00              42,68                7,11            57,68              45,00
4 Produto 04          111,00            118,57              19,76          118,57              92,50
5 Produto 05            38,00              40,59                6,77            40,59              31,67
6 Produto 06          100,00            106,82              17,80          106,82              83,33
7 Produto 07          413,00            441,18              73,53          441,18            344,17
8 Produto 08          512,00            546,94              91,16          546,94            426,67
9 Produto 09          869,00            928,30           154,72          928,30            724,17
10 Produto 10      1.750,00        1.869,41           311,57       1.869,41         1.458,33
11 Produto 11          208,00            222,19              37,03          222,19            173,33

Copie as fórmulas a seguir e cole nas células indicadas e depois copie para as células seguintes na mesma coluna, se solicitado.

Fórmula para a célula G3.

=SE(F3>=1;PROCV(F3;Plan2!B2:G25;2);0)

Fórmula para a Célula E6. Cole também nas células seguintes da mesma coluna.

=SE($F$3<=0;0;ARRED(VF($B$3;$G$3/30;0;-C6);2))-D6

Fórmula para a Célula F6. Cole também nas células seguintes da mesma coluna.

=SE($F$3>=1;E6/$F$3;0)

Fórmula para a Célula G6. Cole também nas células seguintes da mesma coluna.

=E6+D6

Fórmula para a Célula H6. Cole também nas células seguintes da mesma coluna.

=VPL($D$3;C6)

Voc√™ pode criar v√°rias planilhas com base nas f√≥rmulas complexas e quando quiser alterar qualquer dado, nas c√©lulas de refer√™ncias, todos os dados vinculados a ela, ser√£o automaticamente atualizados. O ganho de tempo √© significativo, quando voc√™ trabalha com planilhas eletr√īnicas constru√≠das com f√≥rmulas.


Edivaldo data: 18/01/2018   ✅ 1788

Envie um Coment√°rio

Você deve estar Logado para postar comentários, ou crie um registro em Tudo Excel.