Ocultar Valores Zero Retornados por uma Função do Excel

Quando você adiciona uma função do Excel, em uma célula, se a referência, ou o cálculo que a função está buscando, for ZERO, este valor é exibido na célula.

Por exemplo: você quer usar a função na célula B1, para que ela tenha o mesmo valor de A1. então você vai adicionar a função: =A1.

Se A1 estiver vazia, o valor ZERO é exibido automaticamente. Há outras funções que retornam um hífen, também é possível esconder.

E o que vamos usar, para fazer isso? Usando formatação condicional, ou a função SE

Usando as regras de formatação condicional:

  1. Selecione a célula, ou o intervalo de células, que contem funções e que mostra o valor ZERO.
  2. Na guia Página Inicial, clique na opção de Formatação Condicional, depois em Realçar Regras das Células e em seguida selecione Igual a.
  3. Na caixa à esquerda, digite o valor: 0 (zero).
  4. Na caixa à direita, selecione Formato Personalizado.
  5. Na caixa Formatar Células, clique na guia Fonte.
  6. Na caixa Cor, selecione branco e clique em OK.

O valor ZERO continua na célula, mas oculto, pela cor da fonte.

NOTA: se você mudar a cor de plano de fundo da célula, ou da coluna, ou da tabela inteira, mude a cor na formatação, para que fique igual a cor do plano de fundo.

Ocultar Valores ZERO, com a Função SE.

Ainda exibindo nosso exemplo, vamos aproveitar a mesma planilha, para ocultar o valor ZERO, com função SE.

Se na célula B1, você tem a função =A1, para retornar o valor de A1. Use o seguinte, para ocultar o valor se for ZERO.

=SE(A1="";"";soma(A1))

Veja como ler a fórmula: se A1 = zero, ou estiver vazio; não exibir nada na célula B1; caso contrário exibe a soma de A1.

Quando a função SE tem apenas uma condição, você encontra o caso contrário.

Essa função poderia se também dessa forma: =se(a1<>0;soma(A1);"")

Veja como ler a função nesse formato: se A1 for diferente de ZERO; soma o valor de A1; caso contrário não exibir nada, na célula.

Note, que com a função só é possível somar valores numéricos, qualquer outro caracteres, var retornar o valor ZERO, ou seja, a célula vai ficar em branco.

Confira Estas Planilhas de Excel
Lista de todas as planilhas do site. Confira estas planilhas Premium. Pacote de planilhas de Excel com 17. A melhor opção!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Custo de Obras para construção e reformas de imóveis. Mais vendida! Planilha de Cotação de Preços. Economize dinheiro comprando mais barato!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Orçamento de Obras 2.0. Exatamente o que você precisa para fazer o controle da obra. Planilhas de Controle de Estoque e Vendas. Ótima recomendação para estoques!
Ver Mais Detalhes Ver Mais Detalhes

Edivaldo

Edivaldo

Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

1 Comentário
  1. Existe uma forma de ocultar o zero no word proveniente de mala direta no excel

Deixe uma Comentário

Tudo Excel
Logo
Shopping cart