Como Calcular Médias Ponderadas no Excel

Entenda como calcular médias ponderadas no Excel. No Microsoft Excel, a média ponderada é calculada usando a mesma abordagem, mas com muito menos esforços, porque as funções farão a maior parte do trabalho para você.

Uma média ponderada difere de uma média, em que a média ponderada retorna um número que depende das variáveis ​​de valor e peso. Veja uma definição mais clara!

O que é a média ponderada?

A média ponderada é um tipo de média aritmética em que alguns elementos do conjunto de dados trazem mais importância do que outros. Em outras palavras, cada valor a ser calculado a média é atribuído a um determinado peso.

Calculando a média ponderada usando a função SOMA

Se você tem conhecimento básico da função SOMA do Excel, a fórmula abaixo dificilmente exigirá qualquer explicação, como na fórmula simbólica a seguir.

=SOMA(B3*C3;B4*C4;B5*C5;B6*C6)/SOMA(C3:C6)

Copie e cole o exemplo a seguir, na célula A1 de uma nova planilha de Excel. Use as fórmulas, para calcular as duas médias.

Calculando Média Ponderada
Atividade Grau Peso
Teste 9,8 0,1
Redação 7 0,3
Trabalho de Pesquisa 7,5 0,25
Prova 9 0,35
Resultados Fórmulas usadas
Média Normal 8,325 =MÉDIA(B3:B6)
Média Ponderada 8,105 =SOMA(B3*C3;B4*C4;B5*C5;B6*C6)/SOMA(C3:C6)

Nestas fórmulas, você pode criar resultados oferecendo número, ou referências de células.

Como você pode ver na imagem acima, a fórmula retorna exatamente o mesmo resultado, independente de ser números, ou referências de células. Observe a diferença entre a média normal retornada pela função MÉDIA na célula C8 e a média ponderada na célula C9.

Nota: use sempre referência de células, para criar fórmulas, se você desejar atualizar sua planilha, para que os resultados sejam alterados automaticamente.

Embora a fórmula SOMA seja muito simples e fácil de entender, não é uma opção viável se você tiver uma grande quantidade de elementos para a média. Neste caso, você deve utilizar a função SOMARPRODUTO como demonstrado no próximo exemplo.

Encontrando médias ponderadas com a função SOMARPRODUTO

A função SOMARPRODUTO do Excel se encaixa perfeitamente para esta tarefa, uma vez que é projetada para somar produtos, exatamente o que precisamos. Assim, em vez de multiplicar cada valor por seu peso individualmente, você fornece duas matrizes na fórmula SOMARPRODUTO. Neste contexto, uma matriz é um intervalo contínuo de células, em seguida, divida o resultado pela soma de pesos:

=SOMARPRODUTO(valores_parâmetro;peso_parâmetro)/SOMA(peso_parâmetro)

Supondo que os valores para a média estejam nas células B2: B6 e pesos nas células C2: C6, nossa fórmula média ponderada Sumproduct tem a seguinte forma:

=SOMARPRODUTO(B2:B10;C2:C10)/SOMA(C2:C10)

Ao invés de copiar e colar, tente criar um exemplo de calculo de média ponderada, usando a função matriz, seguindo as dicas deste tutorial.

Então, o que a função SOMARPRODUTO faz é multiplicar o primeiro valor na primeira matriz pelo primeiro valor na segunda matriz e depois multiplica o segundo valor na primeira matriz pelo segundo valor na segunda matriz e assim por diante. Quando todas as multiplicações são feitas, a função adiciona os produtos e retorna essa soma.

Ao usar a função SUM ou SUMPRODUCT para encontrar a média de peso no Excel, os pesos não precisam necessariamente somar até 100%. Nem eles precisam ser expressos como porcentagens. Por exemplo, você pode criar uma escala de prioridade / importância e atribuir um certo número de pontos a cada item, conforme demonstrado na seguinte captura de tela.

Confira Estas Planilhas de Excel
Lista de todas as planilhas do site. Confira estas planilhas Premium. Pacote de planilhas de Excel com 17. A melhor opção!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Custo de Obras para construção e reformas de imóveis. Mais vendida! Planilha de Cotação de Preços. Economize dinheiro comprando mais barato!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Orçamento de Obras 2.0. Exatamente o que você precisa para fazer o controle da obra. Planilhas de Controle de Estoque e Vendas. Ótima recomendação para estoques!
Ver Mais Detalhes Ver Mais Detalhes

Edivaldo

Edivaldo

Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

Teremos o maior prazer em ouvir seus pensamentos

Deixe uma Comentário

Tudo Excel
Logo
Shopping cart