Caixa de Combinação de Controle Active X

Por Edivaldo | 23/02/2015 | 11944 leituras

Vamos mostrar uma dica interessante, para criar planilhas avançadas em Excel.

Para que serve a Caixa de Combinação do controle Active X?

É interessante, para buscar um resumo pré-definido em uma tabela. Se você tem uma tabela extensa e quer imprimir um resumo, para facilitar a visualização, esta é uma boa forma de fazer sua planilha ficar bem interessante e fácil de usar.

Como inserir uma caixa de combinação do controle Active X?

Primeiro verifique se você tem a guia DESENVOLVEDOR acima da barra de ferramentas do Excel.
Mostrar a guia Desenvolvedor.
1. Clique na guia Arquivo.
2. Clique em Opções.
3. Clique em Personalizar Faixa de Opções.
Em Personalizar Faixa de Opções e em Guias Principais, marque a caixa de seleção Desenvolvedor.
Clique em OK para ativar a guia desenvolvedor.
Ver imagem:

guia-desenvolvedor

Criando a Caixa de Combinação no Controle Active X:

Após ter habilitado a GUIA DESENVOLVEDOR, clique sobre ela e em seguida clique em INSERIR na barra de ferramentas, para abrir a caixa de diálogo. Então clique em CAIXA DE COMBINAÇÃO do controle Active X.
Note que há dois tipos de caixa de combinação: formulário e controle Active X, selecione a segunda.

Ver imagem:

insert-caixa-combinacao

Após ter selecionado a opção, clique na planilha e arraste com o mouse, para criar a caixa de combinação no tamanho desejado.
Mantenha ativada a guia desenvolvedor e clique na ferramenta MODO DE DESIGN. Em seguida clique em PROPRIEDADES. Uma janela suspensa vai abrir e você deve localizar os itens:
LinkedCell – define a célula de referência que exibe o nome que você vai selecionar na caixa.
ListFillRange – define o parâmetro da tabela onde contém os dados a serem selecionados.

link-combinacao

Nós criamos uma planilha de exemplo: Clique Aqui e Baixe.

Após definir os parâmetros da tabela, para a caixa de combinação em: LinkedCell e ListFillRange feche a janelinha suspensa, saia do modo design e comece utilizar sua caixa de combinação do controle Active X.
Salve sua planilha: clique em salvar como e escolha a opção PASTA DE TRABALHO HABILITADA PARA MACRO.
Em nosso exemplo de planilha, que você pode BAIXAR AQUI, nós criamos uma tabela simples e usamos a função PROCV, para criar o resumo.
A órmula ficou = PROCV(A5;A10:G20;2;FALSO)
A5 é o LinkedCell – a célula de referência, que já explicamos acima.
A10:G20 é o ListFillRange – tabela que contém os dados dentro de um parâmetro da planilha.
2 é a coluna onde está a informação que eu quero pegar, na mesma linha do nome selecionado.
FALSO é a condição. Se não encontrar ele retorna um valor falso.
Ponto e Vírgula, separa as condições da função PROCV

Obrigado por ler este Post.
Volte sempre ao Tudo Excel

Gostaríamos de saber se ficou alguma dúvida sobre: Caixa de Combinação de Controle Active X. Por favor deixe seu comentário, ou faça sua pergunta.

 

Deixe um comentário

2 Comentários em "Caixa de Combinação de Controle Active X"

avatar
1000
  Opções de Notícias  
Me avisar quando:
Bruno Carvalho
Visitante

Lixo o arquivo de exemplo… tudo bloqueado