Como exibir ou ocultar valores nulos em uma planilha

SalvarSalvoRemovido 3
Dê um Like ❱❱+9
Dê um Like ❱❱+9

No Microsoft Excel tem vários recursos que só descobrimos quando realmente estamos precisando dele. Um destes, é como exibir ou ocultar valores nulos em uma planilha com formatação personalizada.

Muitos usuários tem uma preferência pessoal por ocultar valores zero em uma célula ou pode estar usando uma planilha sujeita a um conjunto de padrões de formato que requerem ocultar os valores zero. Há várias maneiras de exibir ou de ocultar valores zero.

Às vezes, você pode não querer mostrar valores nulos, como por exemplo: ZERO, nas suas planilhas. Mas, em outros casos, talvez seja necessário mantê-los visíveis. Não importa se os seus padrões ou preferências de formato exijam que valores nulos sejam exibidos ou ocultados. Em primeiro lugar, existem várias maneiras de fazer com que isso aconteça.

Ocultar valores zero em células em um intervalo de células ou em toda a planilha

Estas etapas ocultam valores nulos em células selecionadas usando um formato numérico. Os valores ocultos só aparecem na barra de fórmulas e não são impressos. Se o valor em uma dessas células passar a ser diferente de zero, ele será exibido na célula. Dessa forma, seu formato será semelhante ao formato numérico geral. É natural que você adicione uma fórmula e as referências das células ainda estejam vazias. Provavelmente o ZERO aparecerá e neste caso vamos ocultá-lo.

Observação: neste caso os valores de formatos diferentes, se transformarão em números

  • Selecione as células que contêm os valores zero que você deseja ocultar. Você também pode selecionar a planilha inteira.
  • E pode fazer isso pressionando Ctrl+1, ou na guia Página Inicial, clique em Formatar.
  • Em seguida clique em Formatar Células.

Formatar Células na guia Página Inicial

  • Na caixa de diálogo clique em Número e escolha Personalizar.
  • Na caixa Tipo, digite 0;-0;;@

clique em Número e escolha Personalizar

  • Em seguida, clique em OK.

Se você deseja exibir um formato diferente, como um formato moeda por exemplo, entre o um valor como este:

R$ 0,00;-0,00;;@

Para exibir valores ocultos:

Este processo é o mesmo para ocultar valores nulos em um intervalo de células. Você pode fazer todos os passos anteriores e escolher o formato desejado. Ou ainda pode fazer o seguinte:

Selecione as células com zeros ocultos.

Na guia Página Inicial, localize o grupo Número e escolha o formato em uma lista.

Exibir ou ocultar valores nulos em uma planilha

Estas foram as etapas da opção primaria para ocultar valores.

Ocultar ou exibir todos os valores zero em uma planilha

A maneira mais comum para ocultar valores nulos em uma planilha é pela opção Formatar Células. E ainda por cima, você pode selecionar toda a planilha, ou apenas um intervalo de células e aplicar a formatação personalizada. Tudo isso já foi informado acima. Porém agora valos falar de uma opção que oculta, ou exibe estes valores em uma planilha inteira.

Vamos ver como funciona:

  • Inicialmente, clique em Arquivo

Ao abrir o menu na barra lateral esquerda seguida clique em Opções.

Em seguida, na janela pop-up localize e selecione a opção Avançado.

Em Opções de exibição para esta planilha, selecione uma planilha e siga um destes procedimentos:

Para exibir valores nulos (0) nas células, marque a caixa de seleção Mostrar um zero nas células cujo valor é zero.

Para ocultar os valores nulos (0) em exibir células em branco, desmarque a caixa de seleção Mostrar um zero nas células cujo valor é zero.

ocultar valores zero na planilha

Toda a planilha deixará de exibir os valores nulos se você optar por desmarcar esta opção. Por outro lado, toda a planilha poderá exibir valores nulos se você ativar esta opção.

Ocultar valores zero com formatação condicional

  • Selecione a célula que contém o valor zero (0).
  • Na guia Página Inicial, localize o grupo Estilos e clique na opção Formatação Condicional.
  • Escolha a opção: Regras de Realce das Células e, em seguida, selecione Igual a.

Regras de Realce das Células

  • Na caixa à esquerda, digite 0.
  • E na opção à direita, selecione Formato Personalizado.

Escolher formatar personalizado

  • Já na caixa Formatar Células, clique na guia Fonte.
  • Em seguida, na caixa Cor, selecione branco ou a mesma cor do plano de fundo do intervalo selecionado.

Esconder valores com formatação condicional

  • Logo depois, clique em OK para aplicar a formatação.

Exibir valores zero como espaços em branco ou traços adicionando uma fórmula

Use a função SE para fazer isso.

Por exemplo: Os dados estão nas células B3 e B4 em uma planilha do Excel.

Use uma fórmula com esta para retornar uma célula em branco quando o valor for zero:

=SE(B3-B4=0;"";B3-B4)

ou

=SE(B3=0;"";B3-B4)

Você ainda pode usar várias combinações. Use sua imaginação, afinal sua planilha pode exigir isso.

Veja aqui como ler a fórmula: se 0 for o resultado de (B3-aB4), for igual a zero – não exibirá nada. Isso é indicado por aspas "". Se isso não for verdade, exiba o resultado de B3-B4.

Além disso, se você não quiser que as células em branco, mas desejem exibir algo diferente, coloque um traço "-" ou outro caractere entre as aspas.

Ocultar valores zero em um relatório de Tabela Dinâmica

Clique no relatório de tabela dinâmica

Já temos uma postagem que indica como fazer isso. Você pode acessá-la no link a seguir:

Outras opões de ocultar valores nulos em uma planilha podem surgir no Microsoft Excel. A medida que isso for se alterando, esta postagem será atualizada.


Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

Teremos o maior prazer em ouvir seus pensamentos

Deixe uma Comentário

Logo
Registrar Nova Conta
Redefinir Senha