Como converter a data para o nome do mês na planilha de Excel

Às vezes, queremos transformar uma data em apenas o nome do mês, por exemplo: 25/12/2022 em Dezembro. Isso é possível no Excel? Sim, Este tutorial vai demonstrar como obter o nome de um mês a partir de uma data no Excel, usando uma pequena fórmula. E tem mais de uma maneira para obter o nome do mês.

Obter o número do mês usando a função do MÊS

Se você precisar apenas do número do mês de uma data, poderá calculá-lo usando a Função Mês.

Converter a data para o nome do mês na planilha de Excel

Copie a fórmula a seguir e cole em alguma célula de sua planilha de Excel. Depois disso, digite uma data na célula B2 e será exibido o nome do mês independentemente do ano e do dia.

=MÊS(B2)

Obter o número do mês com a função TEXTO

Também pode obter o umero do mês usando a função TEXTO. No entanto, há duas maneiras para esta função, que pode exibir de acordo com a escolha da configuração. Por exemplo: se você quer o número do mês de maio como (5) deve inserir na função apenas um "m". Se deseja obter o número do mês de maio como (05) deve adicionar mais um M "mm"

Vamos ver como fica estas fórmulas:

= texto(b2;"m")
  • Esta opção exibe 5 para o mês de referência em B2, que no nosso exemplo é maio.
= texto(b2;"m")
  • Já esta opção, exibe 05 para o mês de referência na célula B2, que no nosso exemplo, também é maio.

Exibir o nome do mês com a função TEXTO

A função TEXTO retornará o nome do mês quando você inserir o formato de texto "mmmm". Abaixo vamos demonstrar mais formatos de texto para usar. Se você quiser o nome do mês abreviado, precisa retirar um M da fórmula, que ficaria assim: "mmm".

mai 14/05/2022 =TEXTO(B2;"mmm")
maio 15/05/2022 =TEXTO(B2;"mmmm")

A função TEXTO ainda pode ser usada dentro da função ESCOLHER para procurar o mês dentro de uma lista na referência de célula.

Escolher o mês

Dependendo da sua finalidade, você também pode usar a função ESCOLHER para exibir o nome do mês de uma data. Nesta opção você escolhe se quer exibir o nome do mês ou o número.

=ESCOLHER(MÊS(B2);"Janeiro";"Fevereiro";"Março";"Abril";"Maio";"Junho";"Julho";"Agosto";"Setembro";"Otubro";"Novembro";"Dezembro")

Obter mês alterando a formatação

Nos exemplos anteriores, a célula de saída retorna o texto contendo o nome do mês. Em vez disso, você pode simplesmente alterar a formatação da data para exibir apenas o nome do mês. Isso manterá todas as propriedades da data, mostrando apenas o mês.

Ao alterar o formato de data de uma data para “MMMM”, você pode ver o nome do mês:

  • Vá para a guia PÁGINA INICIAL, localize o grupo Número e clique em Formatar.
  • Na janela suspensa clique em Formatar Células.
  • Quando a caixa de diálogo for aberta, clique em Personalizado.
  • Localize a opção Tipo e digite mmmm. Depois clique em OK.
Formato de data personalizada no Excel

Você percebeu que pode obter o resultado visual com fórmulas e, ou com um formato personalizado. Isso mostra que em vários casos no Excel, há mais de uma maneira de fazer as coisas.

Para adicionar mais formatos, nós temos algumas dicas sobre formatação condicional aqui. E você pode aproveitar para deixar sua planilha mais interessante.

Confira Estas Planilhas de Excel
Lista de todas as planilhas do site. Confira estas planilhas Premium. Pacote de planilhas de Excel com 17. A melhor opção!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Custo de Obras para construção e reformas de imóveis. Mais vendida! Planilha de Cotação de Preços. Economize dinheiro comprando mais barato!
Ver Mais Detalhes Ver Mais Detalhes
Planilha de Orçamento de Obras 2.0. Exatamente o que você precisa para fazer o controle da obra. Planilhas de Controle de Estoque e Vendas. Ótima recomendação para estoques!
Ver Mais Detalhes Ver Mais Detalhes

Edivaldo

Edivaldo

Edivaldo. Louco por funções e fórmulas de Excel, adoro fazer planilhas e compartilhar meus conhecimentos com as pessoas. Seja bem-vindo. Eu amo fazer isso e quero compartilhar com você!

Teremos o maior prazer em ouvir seus pensamentos

Deixe uma Comentário

Tudo Excel
Logo
Shopping cart